zakup-r51
?>

Даны два действительных числа. составьте программу, которая заменяет число нулем, если оно меньше второго, или оставляет без изменения в противном случае.

Информатика

Ответы

БашуроваОльга369
Var a,b: real; begin writeln ('введи два вещественных числа'); readln (a,b); if a< b then a: =0 else if b< a then b: =0; writeln (a: 5: 2,' ',b: 5: 2); readln; end. если я правильно поняла.
agafonovalyudmila346
Var   a, b : real; begin   read (a, b);   if (a < b) then a : = 0;   write (a, ' ', b); end.
dvpered

формы представления звуковой информации

компьютер, имеющий звуковую плату, микрофон и акустическую систему, позволяет кодировать (оцифровывать), сохранять и воспроизводить звуковую информацию.

программы для работы со звуком можно условно разделить на две группы: программы-секвенсоры и программы, ориентированные на цифровые технологии записи звука — звуковые редакторы. midi-секвенсоры предназначены для создания и аранжировки музыки. кроме обычного сочинения музыки эффективное использование секвенсора требует от композитора-аранжировщика специальных инженерных знаний.

с звуковых редакторов звуковые файлы можно редактировать: добавлять голоса или музыкальные инструменты, а также разнообразные эффекты.

существуют программы распознавания речи, появляется возможность компьютером при голоса.

звук — это волна с изменяющейся амплитудой и частотой в диапазоне от 20 гц до 20 кгц. чем больше амплитуда, тем громче звук, чем больше частота, тем выше тон.

микрофон превращает звуковую волну в электрический сигнал, а звуковая плата кодирует его, превращая в последовательность нулей и единиц. точность преобразования определяется  разрешающей способностью  преобразователя (8 бит — 256 уровней, 16 бит — 65 536 уровней, 24 бита — 16 777 216 уровней) и числом преобразований (выборок) за 1 с —  частотой дискретизации. (рис.)

при частоте 8 кгц качество оцифрованного звука соответствует радиотрансляции, а при частоте 44,1 кгц — звучанию аудио-cd. студийное качество достигается при 96 или 192 кгц.

разрешение умножим на число выборок за 1 с и на время:

16 • 20 000 • 2 = 640 000 бит = 80 000 байт = 78 кбайт.

закодированный таким образом звуковой фрагмент может быть сохранен в формате  .wav.

в таблице размеры звуковых файлов длительностью звучания 1 с (в килобайтах) при различных разрешениях звуковой карты и частотах дискретизации. для стереозвука размер файла удваивается.

частота дискретизации, кгцразрешение8 бит16 бит24 бит65 53616 777 2167,81315,62523,43823,43846,87570,31344,143,06686,133129,19946,87593,750140,62593,750187,500281,250
alexfold
Дано:   /                           решение:                                                       n=8     /             n=2^i             i=3(бит) k=64/                  i= k*i             i =   64*3=192(бит) i-?                                                                   ответ: 192бит

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны два действительных числа. составьте программу, которая заменяет число нулем, если оно меньше второго, или оставляет без изменения в противном случае.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

departed744
kulturarai44
Павел
tata-novik
iivanov54
cernovarmechta
Dmitrievna Lvovich
timsch12
mikhisakov2017
stic1995
msangelika1010
oksana-popova
oyudina
janepustu
Anait_Natalya451
▲