ocik1632933
?>

Склавиатуры вводятся 2 числа : возраст брата и возраст сестры . программа должна ответить , кто из них старше . дополнительно : в ответе программы должно быть сказано на сколько лет . вторая : признак существования треугольника: каждая его сторана должна быть меньше суммы двух других . написать программу , которая, получив с клавиатуры значения сторон треугольника a, b, c отметит , можно ли построить такой треугольник или нет . написать 2 программы . ! заранее

Информатика

Ответы

lazu8375
1) var x,y: ineger; begin readln(x,y); if x> y then wrietln('x starshe y na', x-y) else writeln('y starhe x na ',y-x); readln; end. 2) var a,b,c: integer; begin if a+b> c then begin if (a+c> b) and (b+c> a) writeln('treygolnik') else writeln('error'); end else writeln('error'); end.
d2002
Самый простой вариант - подсчитать сумму четных и нечётных через цикл, в котором берём остатки от деления. можно начать с конца и соответственно начать подсчитывать сумму только от первого числа с конца не равного 0. подсчитываем через целочисленное деление на круглое число и нахождение остатка при деление на один. данные, чередуя, прибавляем к разным переменным(пусть будут x1 и x2). затем проверяем остаток от деления одной переменной на другую. если 0 - "yes", иначе - "no" for i=5 downto 1 do if i mod 2 = 1 then a: = a+n div (10^(i-1)) mod 10 else b=b+ div (10^(i-1)) mod 10;
Georgievna1407

как-то так:

#include < iostream>

#include < math.h>

using namespace std;

// инициализируем функцию выше функции main, чтоб она была доступна в ней.

void drawline(int n = 0, char sym = '-') {

    // делаем цикл, для рисования символов. fabs(n) - логика такая что: если передается отрицательное, конвертируем его всегда в положительное

    // иными словами: получаем модуль числа.

    // > > ! функция fabs используется и библиотеки #include < math.h> ! < <

    for (int i = 0; i < fabs(n); i++) {

        // выводим символ в консоль

        cout < < sym;

    }

    // отступаем строчку и говорим, что программа закончилась

    cout < < endl < < "finish draw" < < endl;

}

void printcolumn(int n) {

    // конвертируем число n в строку

    std: : string s = std: : to_string(n);

    // делаем цикл по всей строке. s.length вернет ее длинну.

    // любая строка это массив символов, а с массивами мы работаем циклами.

    for (int i = 0; i < s.length(); i++) {

        // выводим символ i в строке s

        cout < < s[i] < < endl;

    }

}

int main()

{

    cout < < "task 30241034! " < < endl; // just for fun

    // вызываем первое. один аргумент т. к. второй уже стоит по умолчанию

    drawline(-3);

    // вызываем второе

    printcolumn(12);

    return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуры вводятся 2 числа : возраст брата и возраст сестры . программа должна ответить , кто из них старше . дополнительно : в ответе программы должно быть сказано на сколько лет . вторая : признак существования треугольника: каждая его сторана должна быть меньше суммы двух других . написать программу , которая, получив с клавиатуры значения сторон треугольника a, b, c отметит , можно ли построить такой треугольник или нет . написать 2 программы . ! заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mexx9050
Александр1991
sergeystepanov231
Шиловский126
Sacharov84
Наталья_Васищев
Aleksei806
Элизбарян
andrey4work918
timonina29
Кристина Валентиновна
serg1976g
okasnab
Burov1446
layna1241383