Lenok33lenok89
?>

Написать программу в кумире. числовой ряд из 10 чисел задается генератором случайных чисел в диапазоне от 1 до 20. найти сумму чисел, кратных 4

Информатика

Ответы

KrisTinka
4+  8+12+6+20  =60; ); ); ); ); ); )
uvarovig
Const n = 5; m = 6; var    a: array[1..n, 1..m] of integer;   c: array[1..n] of integer;   i, j, mx, mn: integer;     begin   randomize;   writeln('исходная матрица');   mn : = 1;   for i : = 1 to n do begin     mx : = -(maxint-1);     for j : = 1 to m do begin       // случайное число от -500 до 500       a[i, j] : = random(1001) - 500;       // выводим       write(a[i, j]: 5, ' ');       // ищем макс в строке       if mx < a[i,j] then mx : = a[i,j];     end;           c[i] : = mx; // макс в строке           // поиск минимума     if c[mn] > c[i] then mn : = i;     writeln;   end;       writeln ('вектор с');   for i : = 1 to n do      write(c[i]: 5, ' ');         writeln(#13, #10, 'минимальный элемент: ');   writeln('c[', mn, '] = ', c[mn]); end.
happygal5224
#include < iostream> #include < vector> int main() {     int b[5][6];     std: : vector< int> vec;     for(int i = 0; i < 5; ++i)         for(int j = 0; j < 6; ++j)             std: : cin > > b[i][j];     for(int i = 0; i < 5; ++i)     {         int max = b[i][0];         for(int j = 1; j < 6; ++j)             if (max < b[i][j])                 max = b[i][j];         vec.push_back(max);     }     int min = vec[0];     int number = 0;     for(int i = 1; i < 5; ++i)            if (min > vec[i])         {             min = vec[i];             number = i;         }     std: : cout < < number; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в кумире. числовой ряд из 10 чисел задается генератором случайных чисел в диапазоне от 1 до 20. найти сумму чисел, кратных 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sohrokova809
alexseyzyablov
verkop9
menesmir
Мусаев Игоревич371
vettime625
annakuznetsova841
Chuhnin195107364
anovikovsr
Gennadievna bessonov
Андрееевич787
Amulenkov
ksenia15-79
Дмитрий-Олейникова
sandovo590