Shishkinna2002
?>

Каждый ежедневно болеющий гриппом человек может заразить окружающих. составьте программу, определяющую, через сколько дней заболеют все ученики школы. число учащихся школы ввести с клавиатуры.

Информатика

Ответы

larson96
При условии что каждый больной заражает от 1 до 5 человек каждый день, и что больные упорно ходят в школу const       min_posible = 1;       max_posible = 5; var all_students, ill, new_ill, days, i: integer; begin       randomize;       writeln('кол-во учеников школы => ');       read(all_students);       ill : = 1;       repeat               days : = days + 1;               new_ill : = 0;               for i : = 1 to ill do                       new_ill : = new_ill + random(min_posible, max_posible);               ill : = ill + new_ill;               writeln('день ',days: 3,': заразилось ',new_ill: 5,' больных ',ill: 5);       until ill > = all_students;       writeln(days); end.
Zashchitin Denis
1) var a,a1,a2: integer; beginreadln(a); a1: =strtoint(copy(inttostr(a),1,1)); a2: =strtoint(copy(inttostr(a),2,1)); if a1> a2 then write(a1,'> ',a2) elsewrite(a1,'< ',a2); end. 2) var a,a1,a2,a3,a4,s: integer; beginreadln(a); a1: =strtoint(copy(inttostr(a),1,1)); a2: =strtoint(copy(inttostr(a),2,1)); a3: =strtoint(copy(inttostr(a),2,1)); a4: =strtoint(copy(inttostr(a),2,1)); s: =a1+a2+a3+a4; if s mod 3 = 0 then write('сумма цифр ',a,'=',s,' - кратно 3')else write('сумма цифр ',a,'=',s,' - не кратно 3'); end.
moskvabelarus
1)            находим количество пикселей, используя для вычисления степени числа 2: n  = 512 · 256 = 29  · 28  = 217 2)            объём файла в  кбайтах  64 = 26 3)            объём файла в битах  26    · 213  = 219 4)            глубина кодирования (количество битов, выделяемых на 1 пиксель): 219  :   217  = 22  = 4 бита на пиксель 5)            максимальное возможное количество  цветов 24  = 16 6)            ответ:   16.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Каждый ежедневно болеющий гриппом человек может заразить окружающих. составьте программу, определяющую, через сколько дней заболеют все ученики школы. число учащихся школы ввести с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

saniopt
sergeystepanov231
jeep75
juliapierrat
is926582086060
perminovaea
orgot9
fermproddk
manager9
Olegmgu11986
tvtanya80
впвыпвып-Зуйков629
Pochkun-Oleg
Valerevna-Vardan
Shalito
▲