Tselyaritskaya Yurevich
?>

Составить программу вычисляющую функцию |x²-x|-7x: (x3-15x) написать ее нужно в паскале,

Информатика

Ответы

dionissia2
Var  x,y: real; begin writeln(введите значение аргумента: '); readln(x); y: =abs(sqr(x)-x)-7*x/(x*x*x-15*x); writeln('значение функции y= ', y: 3: 3); readln; end.
a60ikurgannikova
Ввашем варианте после while необходимо писать begin, а после writeln - end. но само по себе решение некрасивое. вот вам еще два на выбор. 1. без массива var   s,n: integer; begin   write('введите сумму: '); read(s);   n: =s div 5000;   if n> 0 then begin       writeln('банкнот "5000" всего: ',n);       s: =s mod 5000       end;   n: =s div 1000;   if n> 0 then begin       writeln('банкнот "1000" всего: ',n);       s: =s mod 1000       end;   n: =s div 500;   if n> 0 then begin       writeln('банкнот "500" всего: ',n);       s: =s mod 500       end;   n: =s div 100;   if n> 0 then begin       writeln('банкнот "100" всего: ',n);       s: =s mod 100       end;   n: =s div 50;   if n> 0 then begin       writeln('банкнот "50" всего: ',n);       s: =s mod 50       end;   n: =s div 10;   if n> 0 then begin       writeln('банкнот "10" всего: ',n);       s: =s mod 10       end;   if s> 0 then writeln('недоплачено: ',s) end. пример: введите сумму: 162504 банкнот "5000" всего: 32 банкнот "1000" всего: 2 банкнот "500" всего: 1 недоплачено: 4 2. с массивом const   k: array[1..6] of integer=(5000,1000,500,100,50,10); var   s,n,i: integer; begin   write('введите сумму: '); read(s);   for i: =1 to 6 do begin       n: =s div k[i];       if n> 0 then begin           writeln('банкнот "',k[i],'" всего: ',n);           s: =s mod k[i]           end       end;   if s> 0 then writeln('недоплачено: ',s) end. пример введите сумму: 15470 банкнот "5000" всего: 3 банкнот "100" всего: 4 банкнот "50" всего: 1 банкнот "10" всего: 2
Марина566
Var       a, b: real ; begin       write('тормозной путь, определенного для данного места при полном служебном торможении = ');       readln(a);       write('тормозной путь для на 120 км/ч для пассажирских поездов = ');       readln(b);       if b < a then a : = b;       write('тормозной путь для на 80 км/ч для грузовых поездов = ');       readln(b);       if b < a then a : = b;       write('тормозной путь при экстренном торможении с учетом пути, проходимого поездом за время, необходимое для воздействия устройств автоматической локомотивной сигнализации на тормозную систему поезда = ');       readln(b);         if b > a then a : = b;       write('участок, где видимость сигналов менее 400 м? да-1/нет-0 ');       readln(b);       if (b = 1) and (a < 1000) then a : = 1000;       write('железнодорожная линия, вновь оборудуемая автоблокировкой? да-1/нет-0 ');       readln(b);       if (b = 1) and (a < 1000) then a : = 1000;       writeln(a); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисляющую функцию |x²-x|-7x: (x3-15x) написать ее нужно в паскале,
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ambiente-deco516
ekasatkina
snopovajulia
Валентинович133
Telenkovav
mamaevmvv3
autofilters27
Баканова1415
avetisov-84850
anchutk3016
ivanlimeexpo
mitin228133770
Васильевна_Наталья
elenarumack
abramovae
▲