evrotrastop64
?>

Вчем ошибка? пишет "индекс находится вне границ массива" вроде 17 сторока program test; uses crt; var s, s1: string; n, f, i, j, len: integer; begin clrscr; writeln('введите предложение'); readln(s); s: =' '+s; writeln('ведите приставку'); readln(s1); len: =length(s1); n: =0; f: =0; while j< =length(s) do begin if s[j]=' ' then begin for i: =1 to len do if s[j+i]< > s1[i] then f: =1; if f=0 then begin n: =n+1; j: =j+len; end else j: =j+1; end; end; writeln('n=', n); readln; end. в выделенной строке выдает ошибку

Информатика

Ответы

Gennadevich Aleksandr
Смотрите, в этом цикле: while j< =length(s) do     j может быть равно длине строки. а внутри цикла есть вот это:     if s[j+i]< > s1[i]  then f: =1; то есть если s[j] - последний символ, то на этой строчке пойдет обращение уже к несуществующему индексу массива.
dakimov
Не много не понятно, где что стоит, лучше сфотай
neganovaarxi
F=  ¬x +z⇒(x+¬y) таблица истинности: x y z     x+¬y   z⇒(x+¬y)     ¬x       f 0   0   0       1             1                 1       1 0   0   1       1             1                 1       1 0   1   0       0             1                 1       1 0   1   1         0             0                 1        1 1   0   0       1             1                 0       1 1   0   1       1             1                 0       1 1 1   0       1             1                 0       1 1   1   1       1             1                 0       1 f =1 тождественно истинна ,   так как её значения равны 1 при любых x,y,z
info40

ответ редактор видеороликов. Это одна из главных возможностей видеоредактора. В него можно добавить различные клипы, видеоролики, картинки и отредактировать их. За это отвечают функции программы «Клипы» и «Видеоряд».

Инструменты эффектов. Данный инструмент программы умеет добавлять в видео текстовые эффекты, субтитры, регулирует цвета видео, изменяет скорость видео, поворот и другое.

Аудио. В этом разделе программы добавляют аудио-файлы с компьютера, записывают свой голос (предварительно подключите микрофон к компьютеру), сможете добавить диск с аудио дорожкой или другую музыку. Затем, ее можно отредактировать в этом редакторе, например, наложить музыку на видео.

Экспорт. Данная возможность программы ВидеоПад, позволяет экспортировать видео из программы на компьютер. Видео можно сохранить на компьютер в форматах AVI, MOV, mp4 и другие. Если есть канал на Ютубе, можете через программу добавить видео на Ютуб.

Программы. Утилита VideoPad имеет дополнительное ПО, которое может редактировать видео или аудио, создавать записи экрана, графику и другое. Для этого есть раздел «Программы» в редакторе. В нем сможете выбрать нужные варианты программ.

Быстрый просмотр. С этой функции можно смотреть, прослушивать, отредактированное аудио или видео – прямо в программе.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вчем ошибка? пишет "индекс находится вне границ массива" вроде 17 сторока program test; uses crt; var s, s1: string; n, f, i, j, len: integer; begin clrscr; writeln('введите предложение'); readln(s); s: =' '+s; writeln('ведите приставку'); readln(s1); len: =length(s1); n: =0; f: =0; while j< =length(s) do begin if s[j]=' ' then begin for i: =1 to len do if s[j+i]< > s1[i] then f: =1; if f=0 then begin n: =n+1; j: =j+len; end else j: =j+1; end; end; writeln('n=', n); readln; end. в выделенной строке выдает ошибку
Ваше имя (никнейм)*
Email*
Комментарий*