б
Объяснение:
1) Рассмотрим эти два интервала времени. Допустим, что интервал noon начался раньше интервала pass. Это значит, что noon[0]<pass[0]. Если же эти два интервала пересекаются, то конец noon будет позже начала pass. А это значит, что noon[1]>pass[0]. Само собой разумеется, что noon[0] будет тогда раньше, чем pass[1] (noon[0]<pass[1]).
2) Рассмотрим теперь второй случай, когда интервал pass начался раньше noon и эти два интервала пересекаются. Получается, что тогда noon[0] расположен между pass[0] и pass[1]. А это значит, что верны следующие два выражения: pass[0]<noon[0] и noon[0]<pass[1]. Тогда, так как noon[1]>noon[0] и в то же время pass[0]<noon[0], то pass[0]<noon[1]. Или, если записать наоборот, то noon[1]>pass[0]
3) Обратим внимание, что и в первом, и во втором случае выполняются те выражения, которые выделены жирным шрифтом. А это значит, что noon[1]>pass[0] и noon[0]<pass[1] верны при любых обстоятельствах. Значит из предложенных вариантов ответов, правильный ответ под буквой б.
--- C# 7.3 -- (.NET Framework 4.8)
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace CSLear
{
class Program
{
static void Main(string[] args)
{
Tuple<int, int> MatrixRange = new Tuple<int, int>(-10, 10);
int M = int.Parse(Console.ReadLine());
int N = int.Parse(Console.ReadLine());
int[,] Arr = new int[M,N];
ArrayRandomize(ref Arr, M, N, MatrixRange);
MatrixPrint(Arr, M, N);
int Negatives = Arr.Count(x => x < 0);
int Zero = Arr.Count(x => x == 0);
int Positives = Arr.Count(x => x > 0);
Console.WriteLine($"Positive Items: {Positives}\nNegative Items: {Negatives}\nZeroes: {Zero}");
Console.ReadKey();
}
public static void MatrixPrint<T>(T[,] Matrix, int MRows, int MCols)
{
StringBuilder sb = new StringBuilder();
for (int i = 0; i < MRows; i++)
{
for (int j = 0; j < MCols; j++)
{
sb.Append($"{Matrix[i, j]} ");
}
sb.Append("\n");
}
Console.WriteLine(sb.ToString());
}
public static void ArrayRandomize(ref int[,] Arr, int ArrRows, int ArrCols, Tuple<int, int> Range)
{
Random r = new Random();
for (int i = 0; i < ArrRows; i++)
{
for (int j = 0; j < ArrCols; j++)
{
Arr[i, j] = r.Next(Range.Item1, Range.Item2);
}
}
}
public static class Extensions
{
public static int Count<T>(this T[,] Matr, Func<T, bool> Predicate)
{
int counter = 0;
foreach (T Item in Matr)
{
if (Predicate(Item)) counter++;
}
return counter;
}
}
}
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
1. определите значение переменной s после выполнения операторов: i: =0; s: =0 while i< 3 do begin i: =i+1; s: =s+i*i end; a. 0 b. 3 c. 11 d. 14 e. 18 2. сколько строк напечатает программа: var k, l: integer; begin for k: =8 downto 1 do for l: =10 to 14 do writeln(‘мне нравится паскаль.’); end. 8 10 14 верного ответа нет, 3 .что выведется на экран в результате выполнения фрагмента программы: s: =0; for j: =10 to 15 do begin s: =s+2*j; write(‘ j=’, j: 2, ’ s=’, s: 4) end;