frame45
?>

Напишите программу для решения . с2.даны целые числа a, b, с.если а≤b≤c, то все числа замените квадратами, если а> b> c, то каждое число замените наибольшим из них, в противном случае смените знак каждого числа. с2.по номеру месяца выдайте квартал, которому он принадлежит.

Информатика

Ответы

masum-2011687
Var a,b,c: integer; begin readln(a,b,c); if (a< =b) and (b< =c) then begin a: =a*a; b: =b*b; c: =c*c; end else if (a> b) and (b> c) then begin if a< b then a: =b; if a< c then a: =c; b: =a; c: =a; end  else      begin        a: =a*(-1);         b: =b*(-1);         c: =c*(-1)      end;   writeln(a: 4, b: 4, c: 4); end.
vera2job7

В закрепе

Объяснение:

Чтобы можно было играться с отдельными символами разобьём строку на список

text_list = list(input())

Для того чтобы достать определённый элемент нужно написать его индекс в списке. Индексация начинается с 0.

Например чтобы получить первый символ нужно достать символ с индексом 0 - text_list[0]

Чтобы получить диапазон используется ":": text_list[0:5] чтобы получить элементы от 1 до пяти

Чётные/не чётные с третьего аргумента range() (какое начисление за цикл)

Для обратного порядка reversed()

Для подсчёта длины len()

nata27-73589

//произведение двух минимальных чисел в последовательности

begin

  var x: integer;

  read(x);

  var min1 : = maxint;

  var min2 : = maxint;

  repeat

    if x < = min1 then

    begin

      min2 : = min1;

      min1 : = x

    end

    else if x < min2 then

      min2 : = x;

    read(x);

  until x = 0;

  if (min1 < > maxint) and (min2 < > maxint) then

    print(min1 * min2)

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для решения . с2.даны целые числа a, b, с.если а≤b≤c, то все числа замените квадратами, если а> b> c, то каждое число замените наибольшим из них, в противном случае смените знак каждого числа. с2.по номеру месяца выдайте квартал, которому он принадлежит.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ogofman
Shago
Andrei Morozov
Гаевая1290
Veselova
ocik1632933
rnimsk149
Виктория-Марина626
shmanm26
olgabylova6223
Pastel-sova
nkochladze
kirillreznikov
gusrva3001
yusovd291