Написать программу решения (abc pascal вы купили в магазине x порций мороженого по цене 35 рублей каждое и y шоколадок по 60 рублей. сколько всего денег вы потратили?
Var x,y,s: integer; begin readln(x,y); s: =35*x+60*y; writeln(s) end.
borisovaks496
28.01.2021
Y: = round(3*7 div y mod 7/3)/y – trunc(0.724) для удобства анализа введем добавочные скобки и пробелы. y : = round( ( (3 * 7) div y ) mod (7 / 3) ) / y – trunc(0.724) 3*7 даст величину целочисленного типа.тип переменной y в операции (3*7) div y может быть по определению этой операции только целочисленным. целочисленным будет и её результат.деление 7/3 даст результат вещественный, так уж устроена операция "/"получаем по типам: < целочисленный> mod < вещественный> . операция mod определена только для целочисленных операндов, поэтому тут ошибка.
manager6
28.01.2021
// pascalabc.net 3.0, cборка 1052 var a: integer; i, j, max: integer; function f(a, b: integer): integer; begin if a > b then result : = a else result : = b end; begin randomize; max: =-1; write('набор чисел: '); for i : = 1 to 5 do begin a: = random(10); write(a,' '); max: =f(max,a) end; writeln(#13#10,'максимальное число равно ',max) end. тестовое решение: набор чисел: 6 8 5 1 2 максимальное число равно 8