pisikak999
?>

Напишите программу на заранее огромное ! 2.дан прямоугольный треугольник. значение двух катетов вводится пользователем с клавиатуры. необходимо посчитать и вывести на экран значение гипотенузы и периметра треугольника. 3.требуется написать программу, которая будет вычислять стоимость покупки в магазине канцтоваров. для определённости будем считать, что в покупаемый набор входят тетради и ручки (и тетради и ручки одного вида с клавиатуры вводят: стоимость одной тетради, стоимость одной ручки, количество тетрадей и количество ручек. 4.требуется написать программу, которая должна рассчитать время поездки из пункта a в пункт с. при этом необходимо сначала доехать по шоссе из а в в, а затем по грунтовой дороге из в в пункт с. длины путей (в километрах) из а в в и из в в с вводятся с клавиатуры. также с клавиатуры вводятся скорости по шоссе и по грунтовой дороге. время в пути необходимо вычислить до часа (следует округлить вычисленное значение).

Информатика

Ответы

Veril8626
2. var a,b: integer; begin; writeln(' чтобы узнать площадь треугольника введите его катеты');   readln(a,b); var c: =sqrt(a*a+b*b); writeln('гипотенуза данного треугольника =',c); writeln('площадь =',a*b/2) end.
hadzievamareta44

Устройства ввода подразделяются на следующие категории:

устройства ввода графической, звуковой и видео информации;

механические устройства ввода;

непрерывные устройства ввода (устройства, предоставляющие входные данные непрерывно, например, мышь, радиоприёмник, ТВ-тюнер);

устройства ввода для использования (например, двухмерная мышь, трёхмерный навигатор).

Компьютерные указывающие устройства ввода по управления курсором делят на следующие категории:

указывающие устройства прямого ввода (управление осуществляется непосредственно в месте видимости курсора (например, сенсорные панели и экраны));

непрямые указывающие устройства (например компьютерная мышь).

Объяснение:

Galina
//pascal abc.net v3.0 сборка 1111 //1 var   ar: array[1..5] of integer;   min,i: integer; begin   min: =2147483647;   for i: =1 to 5 do   begin     readln(ar[i]);     if ar[i]< min then min: =ar[i];   end;   write('min=',min); end.пример ввода: 6-6345пример вывода: min=-6//2var  ar: array[1..20] of integer;   i,s: integer; begin;   randomize;   s: =0;   writeln('array: ');   for i: =1 to 20 do    begin;     ar[i]: =random(101);     write(ar[i]: 4);     if ar[i] mod 7=0 then s: =s+ar[i];     end;   writeln;   write('sum=',s); end.пример работы программы: array:   13   23   70   67   0   82   16   66   48   54   46   99 100   75   48   33   1   88   9   73sum=70

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на заранее огромное ! 2.дан прямоугольный треугольник. значение двух катетов вводится пользователем с клавиатуры. необходимо посчитать и вывести на экран значение гипотенузы и периметра треугольника. 3.требуется написать программу, которая будет вычислять стоимость покупки в магазине канцтоваров. для определённости будем считать, что в покупаемый набор входят тетради и ручки (и тетради и ручки одного вида с клавиатуры вводят: стоимость одной тетради, стоимость одной ручки, количество тетрадей и количество ручек. 4.требуется написать программу, которая должна рассчитать время поездки из пункта a в пункт с. при этом необходимо сначала доехать по шоссе из а в в, а затем по грунтовой дороге из в в пункт с. длины путей (в километрах) из а в в и из в в с вводятся с клавиатуры. также с клавиатуры вводятся скорости по шоссе и по грунтовой дороге. время в пути необходимо вычислить до часа (следует округлить вычисленное значение).
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Смирнов_Андрей691
denchiklo2299667
moskvabelarus
shuramuji
victoriapetrs
Анатольевич-Митюшин
Mexx9050
borzhemskaya19823110
Araevich
Попов1946
TatiyanaBe20135263
manuchar-formen2
tihonovrv477
struev2003260
andre6807