bondarev05071962
?>

Нужно написать программу в паскали авс. условие: нужно возвести число а в 20 степень. заранее !

Информатика

Ответы

Vasilisan
Есть функция power var a: integer; begin readln(a); writeln(power(a,20)); end.если нужно без ее , то цикломvar i,a,r: integer; beginr: =1; readln(a); for i: =1 to 20 dor*=a; writeln(r); end.
yuliyaminullina

вот пример последовательного ал­горитма.

алгоритм приготовления бутерброда

отрезать ломтик хлеба.намазать хлеб маслом.отрезать ломтик сыра.положить сыр на хлеб.конец алгоритма

однако в окружающем нас мире многие события и явления по­вторяются. день сменяет ночь, после ночи вновь наступает день; из года в год чередуются весна, лето, осень и зима; в песнях повторяются припе­вы. человеку тоже часто приходится выполнять повторяю­щиеся действия. например, ходьба — это повторение движений ног: шаг правой — шаг левой. чистка картофеля, мытье тарелок, зата­чивание карандашей предполагают повторение одних и тех же дей­ствий.

если в алгоритме можно выделить последовательность действий, которая выполняется несколько раз подряд, то такой алгоритм  называют  циклическим.

в графических изображениях часто можно увидеть одинаковые элементы. однако нарисовать две абсолют­но одинаковые фигуры сложно, по­этому в графическом редакторе существует возможность сделать копию повторяюще­гося фрагмента, а затем вставить ее в рису­нок столько раз, сколько потребуется.

Konstantinovich alekseevna993
// pascalabc.net 3.2, сборка 1362 от 14.12.2016 // внимание! если программа не работает, обновите версию! procedure love(n: integer); begin   writeln(n*('я люблю паскаль'+newline)) end; begin   love(readinteger('n=')) end. пример n= 5 я люблю паскаль я люблю паскаль я люблю паскаль я люблю паскаль я люблю паскаль // pascalabc.net 3.2, сборка 1362 от 14.12.2016 // внимание! если программа не работает, обновите версию! procedure linequ(a,b: real); begin   if a=0 then       if b=0 then writeln('решений бесконечно много')       else writeln('решений нет')   else writeln('x=',-b/a) end; begin   var a,b: real;   write('введите а и b: '); read(a,b);   linequ(a,b) end. пример введите а и b: 18.45 -12 x=0.650406504065041

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу в паскали авс. условие: нужно возвести число а в 20 степень. заранее !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Маркина Ворошилина
Mamikin
keykov35
troian07
Shcherbinin KOLIChEVA
Vyacheslavovna
зырянов_Юрьевна378
dmtr77
kseniyavaganova
Volkov
tsarkovim
M10M11M12
zodgener
kozhevniks
elena-ruzadom