mishagoride885
?>

Составьте программу, заполняющую массив заданной размерности случайными целыми числами и обрабатывающую его в соответствии с вариантом . обратите внимание на правильное использование типов данных (помните, что результат операции может отличаться от типа исходных данных исходный массив: s[0..75] что требуется сделать: изменить знак всех четных элементов массива с четными индексами

Информатика

Ответы

Борисовна_Кашутина

ответ:

program youname;

var i,n: integer;

s: array[0..75] of integer; // объявление массива

begin

write('введите количество элементов массива: ');

readln(n); // ввод кол-ва элементов массива

writeln('----------------------------------------');

writeln('исходный массив: ');

for i: =1 to n do // перебор от первого до n элементов массива

  begin

  // если используете паскаль abc, то можно написать так: s[i]: =random(-100,100);

  s[i]: =random(100-(-100)+1)+(-100); // заполнение элементов массива от -100 до 100.

  write(s[i], '(', i, ')',' '); // вывод элемента массива с его порядковым номером

  end;

writeln;

writeln('----------------------------------------');

writeln('видоизмененный массив: ');

for i: =1 to n do // перебор от первого до n элементов массива

  begin

  if (i mod 2 = 0) and (s[i] mod 2 = 0) then // если элемент и значение массива четное, то..

    begin

    s[i]: =s[i]*(-1); // смена знака на противоположный

    write(s[i], '(', i, ')',' '); // вывод элемента массива с его порядковым номером

    end;

  end;

writeln;

writeln('----------------------------------------');

end.

объяснение: если есть вопросы, то пишите мне в лс.

okarp
Во втором наборе букв зашифровано слово berry
Asira926

const n=100;

program Zadacha1;

ver a: array [1.. n] of real;

x:: real; i: integer;

begin;

writeln ('Введите элементы массива');

for i = 1 to n do red (a [i])

writeln ('Введите значение для поиcка')

read (x);

for i:=1 to n do

if a[i] == x then

writeln ('на ', i, 'месте массива находится заданный элемент', x:8:2);

end!

Объяснение:

В первой строке пропустил ";".

В пятой написал began, а правильно begin.

В седьмой между i и = не должна быть ";", при этом для цикла for нельзя ставить ";".

В восьмой не посика, а поиска, еще забыл ";".

И на последней строчке не enn, a end.

sde19755511

В квадратиках, где символы не открываются вставлял строгие выражения.

#define _USE_MATH_DEFINES

#include <iostream>

#include<cmath>

signed main() {

double x, z;

std::cout << "x=";

std::cin >> x;

if (x < -M_PI)

 z = log(abs(x));

else if (-M_PI < x < M_PI)

 z = sin(x) + cos(2 * x);

else if (M_PI < x < 10)

 z = pow(x, 3) + 1;

else if (10 < x < 100)

 z = (x + 1) / (x * x + 8);

else

 z = log(x);

std::cout << z << std::endl;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, заполняющую массив заданной размерности случайными целыми числами и обрабатывающую его в соответствии с вариантом . обратите внимание на правильное использование типов данных (помните, что результат операции может отличаться от типа исходных данных исходный массив: s[0..75] что требуется сделать: изменить знак всех четных элементов массива с четными индексами
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

missbuhgalter2013
Varezka86179
ghjcnjtyjn64
opel81
Belik-elena20111
barekyan096140
xarchopuri22
Климова1317
Nadirovich1317
siren89
a800000
мурувватовна викторович569
igorevich-alekseevna
dokmak140652
nmakarchuk