Татьяна_Полулях
?>

Составить программу, которая запрашивает у пользователя целое число и выводит квадрат, куб, и пятую степень этого числа. !

Информатика

Ответы

Aleksei1463
Var  i: integer; begin write('введите число '); readln(i); writeln('квадрат этого числа= ',i*i); writeln('куб этого числа= ',power(i,3)); writeln('пятая степень этого числа= ',power(i,5)); end.
makarov021106
Программистом не станешь, закончив институт - программист это постоянное самообразование и бесчисленные часы, проведенные в практике. вы получите хорошую базу, закончив мфти, мифи, мгту и прочие из серии. я закончил один из серии подобных вузов и поверьте, единственное что они - топовую корочку о высшем образовании, с которой вас будут в хороших it компаниях и, если вы захотите продолжить обучение, вам база пригодится в магистратуре. остальное - самообразование, изучение новых языков программирования, совершенствование в написании алгоритмов.
picsell
    раскладываем по степеням двойки: 67 (10cc) = 64+2+1 = 2^6+2^1+2^0 = 1 000 011 (2cc) или   67  |2   66 |   | 33 | 2     1   32 |         | 16 |2             1| 16 |                 | 8| 2                   0| 8|                         | 4|2                         0| 4|                             --|2|2                             0|2|                               --| 1     <   первая цифра в числе и далее - остатки                               049 (10cc)=32+16+1=2^5+2^4+2^0=110  001 (2cc) 54= 32+16+4+2= 2^5+2^4+2^2+2^1= 110 110 (2cc) 81=64+16+1=2^6+2^4+2^0=1 010 001 (2cc)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая запрашивает у пользователя целое число и выводит квадрат, куб, и пятую степень этого числа. !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

d43irina
Janaz842060
savenko0109152
kristinmk
evoque2014
ikhilovb76
Valerii276
Екатерина_Кирушев
ams-sim
thebest59
mstrshulz
Buninilya
Chuhnin195107364
zanthia94
Анатолий
▲