Shlapakov1911aa
?>

Если в заданной матрице a(n, m) есть хотя бы один элемент, больший ста, то элементы обеих диагоналей замените нулями. написать программу на pascal

Информатика

Ответы

abdulhakovalily22
Program  gt; var  a: array[1..100,1..100]of  integer; n,m,i,  j  ,q: integer; begin read(n,m); q: =0; for  i: =1 to n do for j: =1 to m do begin read(a[i,  j]); if(a[i,  j]> 100)then q: =1; end; if(q=1)then begin   for i: =1 to n do for j: =1 to m do if(i=j)or(i=m-j+1)then  a[i,j]: =0;   end; for i: =1 to n do begin for j: =1 to m do write(a[i,  j],' '); writeln; end; end.
krasnova1977
1) цикл от 2 включительно, до 20 включительно. 2) видим первое условие: i> =3 и i< =8 соответственно, когда циклическая переменная будет равна 3 (i=3) будет выполнено условие. а также при i=9 условие не будет выполняться. 3) видим второй блок условий. они подразумевают, что квадрат переменной не должен быть выше границы в 20 единиц. берем на заметку, что квадрат 5 равен 25, что является подходящим под условие и принудительно завершит цикл. 4) итак, при первом цикле переменная равна 2. ни одно из условий не выполниться. при i=3 выполниться первое условие и сумма увеличиться на остаток от деления i на 2, т.е. на 1. это условие будет выполняться до 5, позже цикл прервёт второе условие. значит необходимо посчитать остатки от деления i (3..5) на 2. ответ: 2
elenaneretina
Определим как работает условия и циклы в программировании. условия бывают строгие и не строгие. строгие- это когда число либо больше, либо меньше, либо равно числу или не равно. не строгие - это когда число либо больше или равно, либо меньше или равно. циклы работают по принципу: пока что условие выполняется, делать цикл. в данном случае i=1 и условие i> 1 строгое. т.е. если бы i=2, то условие бы выполнилось. в данном случае i=1 => i> 1 не выполняется и цикл не запуститься. ответ: 0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Если в заданной матрице a(n, m) есть хотя бы один элемент, больший ста, то элементы обеих диагоналей замените нулями. написать программу на pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

premiumoft
oshemkov579
Nekrasova
fednik3337923
klimenokvapeshop1408
denspiel
Maly01984489
Сергей_Евгеньевич1255
printlublino
afomin63
mgg64
владимировнаКлютко
alexander4590
Аношкина1696
Nevstrueva_Vasilevna