nadezhda81
?>

Составить программу которая определяет по номеру месяца соответствующее время года

Информатика

Ответы

larson96
Var s: string;     i: integer; begin     write('строка:   ');       readln(s);       i: =1;     while i< =length(s) do     begin       if s[i]='-' then       begin         s: =copy(s,1,i-1)+' '+s[i]+' '+         copy(s,i+1,length(s)-i+3);         i: =i+2;     end;     i: =i+1;   end;   writeln('новая строка:   ',s); end.     
AMR89154331531
Для начала посчитаем сколько символов в твоем предложении (пробелы, знаки препинания, буквы). их там 28 [терпение и труд все перетрут]. как мы знаем, в кодировке unicode -  1 символ занимает 16 бит памяти. умножим 28 символов на 16 и получим 448 бит [28*16=448  бит]. теперь, если это требуется, переведем биты в байты и килобайты. 1 байт памяти занимает 8 бит. делим 448 бит на 8 получаем 56 [448/8=56 байт]. 1 кбайт памяти, в свою очередь, занимает 1024 байт памяти. делим 56 байт на 1024 (советую использовать калькулятор) получаем 0,05 кбайт [56/1024= 0,0546875]. в ответе пишем одно из получившихся значений, которое требуется написать [448 бит или 56 байт или 0,05 кбайт]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая определяет по номеру месяца соответствующее время года
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cheshirsky-kot
andreanikin
agaloan8
Vos-sv
Pervosha
rusplatok
Ионов202
Наталья
lenapopovich556510
alexandergulyamov
Маринина_Елена
Некрасов Валентина1097
annino
denbelousov963
zrv85