migreen
?>

Написать программу-калькулятор, выполняющую 4 действия. в программе паскаль .

Информатика

Ответы

janetp
Var numb1,numb2 : integer; s: string; begin readln(s); readln(numb1,numb2); if (s = '+') then writeln(numb1+numb2); if (s = '-') then writeln(numb1-numb2); if (s = '*') then writeln(numb1*numb2); if (s = '/') then writeln(numb1/numb2); end.
miss1380

початок

1. наповнити *7* // маємо 7 л

2. перелити з *7* в *2* // лишилось 5 л у *7*

3. вилити *2* // *2* - порожній

4. перелити з *7* у *2* // лишилось 3 л у *7*

кінець

 

пояснення

*7* і *2* - глечики

наповнити х - команда означає набрати в глечик х стільки води, щоб він став повним

перелити з х в у - команда означає перелити  з глечика х в глечик у стільки води, щоб глечик у став повним

вилити х - команда означає вилити з глечика х всю воду

все, що розміщено після // і до кінця рядка - коментар (виконавець його ігнорує)

 

elenachuxina804

uses crt; const max=100; var a: array[1..max] of integer; n,i,imn,imx: byte; x: integer; begin clrscr; randomize; repeat write('размер массива n: '); readln(n); until n in [1..max]; writeln('исходный массив: '); for i: =1 to n do begin a[i]: =random(20)+1; write(a[i],' '); end; imn: =1; imx: =1; for i: =1 to n do begin if a[i]< a[imn] then imn: =i; if a[i]> a[imx] then imx: =i; end; writeln('минимальный элемент: ',a[imn],' его индекс: ',imn); writeln('максимальный элемент: ',a[imx],' его индекс: ',imx); x: =a[imn]; a[imn]: =a[imx]; a[imx]: =x; writeln('обмне максимального и минимального: '); for i: =1 to n do write(a[i],' '); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу-калькулятор, выполняющую 4 действия. в программе паскаль .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovna Yevtodeva
alina-bas
abahtina582
tushina2020
Михайлович Гуртовая929
sharikplushelen
Anastasiya1537
jakushkinn
goodsled
seymurxalafov05
beaevgen711
Tarapovskaya
kulibabad566
jnrhjq3597
Stepanovich_Makarov