seregina19706867
?>

6.нужно написать программу в с++. определить класс «студент». сведения о студенте состоят из его фамилии, оценок по сессии, номера курса и кода группы, в которой он учится. предусмотреть возможность вывода фамилий и номеров групп для студентов, имеющих оценки 4 и 5; обеспечить вывод информации о студентах группы, код которой вводится с клавиатуры. если таких студентов нет, вывести соответствующее сообщение. (максимальная оценка «хорошо»

Информатика

Ответы

s2010av565
Var a,b,c,m1,m2,m3,max: integer; function sum(n: integer): integer; var s: integer; begin s: =0; n: =abs(n); while n> 0 do   begin   s: =s+n mod 10;   n: =n div 10;   end; sum: =s; end; begin write('a, b, c: '); readln(a,b,c); m1: =sum(a); m2: =sum(b); m3: =sum(c); writeln('m1 = ',m1,' m2 = ',m2,' m3 = ',m3); if m1> m2 then max: =m1 else max: =m2; if m3> max then max: =m3; writeln('max = ',max); end. пример: a, b, c: 45 -3549 138 m1 = 9 m2 = 21 m3 = 12 max = 21
galkar
// pascalabc.net 3.2, сборка 1403 от 16.03.2017 // внимание! если программа не работает, обновите версию! function sumdigits(n: integer): integer; begin   result: =0;   while n> 0 do begin       result+=n mod 10;       n: =n div 10       end end; begin   var s: =readarrinteger('вводите: ',3).select(x-> sumdigits(;   var i: =s.indexmax;   var k: =s.where(x-> x=s[i]).count;   case k of       1: begin           write('сумма цифр наибольшая у ');           case i of               0: write('первого');               1: write('второго');               2: write('третьего');               end;           writeln(' числа')           end;       2: begin           write('сумма цифр наибольшая у ');           if s[0]=s[1] then writeln('первого и второго чисел')           else               if s[0]=s[2] then writeln('первого и третьего чисел')               else writeln('второго и третьего чисел')           end;       3: writeln('суммы цифр у всех трех чисел равны')       end end. примеры вводите: 102030 324 19 сумма цифр наибольшая у третьего числа вводите: 16453 4320 56341 сумма цифр наибольшая у первого и третьего чисел вводите: 12345 12354 54321 суммы цифр у всех трех чисел равны

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

6.нужно написать программу в с++. определить класс «студент». сведения о студенте состоят из его фамилии, оценок по сессии, номера курса и кода группы, в которой он учится. предусмотреть возможность вывода фамилий и номеров групп для студентов, имеющих оценки 4 и 5; обеспечить вывод информации о студентах группы, код которой вводится с клавиатуры. если таких студентов нет, вывести соответствующее сообщение. (максимальная оценка «хорошо»
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

platan3698952
pimenovamar
smirnovaL1286
iivanovar-da
петрАфанасьев
Курнев-Анастасия359
Вера1072
a800000
dakimov
wwladik2606222
baton197310
perovd8111
dushechkin2
Alisa
egcuzn86