olyafom1234
?>

Написать программу вычисляющую выражения. z=(sqr(x+1)*(x-(18*x*y))

Информатика

Ответы

Спиридонова

var

z,x,y: longint;

begin

write ('x = > '); readln(x);

write ('y = > '); readln(y);

z: =(sqr(x+1)*(x-(18*x*y));

writeln ('z = ',z);

readln;

end. 

vik1223

возможно это  microsoft office excel 

Пономаренко
Перевести числа: 0,345; 400; 256 (из восьмиричной в двоичную) f0c,ff; aa ( из шестнадцатиричной в двоичную)и 765,25 из шестнадцатиричной в двоичную. заранее   ответпокажу на примере первого числа. 1) переводим в двоичную. сначала целую часть делением: 312 : 2 = 156 ост. 0 156 : 2 = 78 ост. 0 78 : 2 = 39 ост. 0 39 : 2 = 19 ост. 1 19 : 2 = 9 ост. 1 9 : 2 = 4 ост. 1 4 : 2 = 2 ост. 0 2 : 2 = 1 ост. 0 1 : 2 = 0 ост. 1 для дробной нужно определиться сколько знаков после запятой нам нужно. пусть будет 8, чтобы в шестнадцатеричной получилось 2… ,96 · 2 = 1,92 ,92 · 2 = 1,84 ,84 · 2 = 1,68 ,68 · 2 = 1,36 ,36 · 2 = 0,72 ,72 · 2 = 1,44 ,44 · 2 = 0,88 ,88 · 2 = 1,76 следовательно 312,96 (10) → 100111000,11110101 (2) для перевода из двоичной в восьмеричную и шестнадцатеричную нужно разбить на тройки и квадры влево и вправо от запятой, при необходимости дописав нули: 100 111 000,111 101 010 (2) → 470,752 (8) 1 0011 1000,1111 0101 (2) → 138,f5 (16) теперь сделаем проверку: 4*8*8 + 7*8 + 7/8 + 5/8/8 + 2/8/8/8 = 256 + 56 + 0,875 + 0,078125 + 0,00390625 = 312,95703125 1*16*16 + 3*16 + 8 + 15/16 + 5/16/16 = 256 + 48 + 8 + 0,9375 + 0,01953125 = 312,95703125 если полученный результат округлить до 2 знаков после запятой,  то получится исходное число!
jnrhjq3597
Звуковая информация. звук представляет собой распространяющуюся в воздухе, воде или другой среде волну с непрерывно меняющейся интенсивностью и частотой. человек воспринимает звуковые волны (колебания воздуха) с слуха в форме звука различных громкости и тона. чем больше интенсивность звуковой волны, тем громче звук, чем больше частота волны, тем выше тон звука (рис. 1.1). рис. 1.1. зависимость громкости и высоты тона звука от интенсивности и частоты звуковой волны человеческое ухо воспринимает звук с частотой от 20 колебаний в секунду (низкий звук) до 20 000 колебаний в секунду (высокий звук). человек может воспринимать звук в огромном диапазоне интенсивностей, в котором максимальная интенсивность больше минимальной в 1014 раз (в сто тысяч миллиардов раз). для измерения громкости звука применяется специальная единица "децибел" (дбл) (табл. 5.1). уменьшение или увеличение громкости звука на 10 дбл соответствует уменьшению или увеличению интенсивности звука в 10 раз. таблица 5.1. громкость звука звук громкость в децибелах нижний предел чувствительности человеческого уха 0 шорох листьев 10 разговор 60 гудок автомобиля 90 реактивный двигатель 120 болевой порог 140 временная дискретизация звука. для того чтобы компьютер мог обрабатывать звук, непрерывный звуковой сигнал должен быть преобразован в цифровую дискретную форму с временной дискретизации. непрерывная звуковая волна разбивается на отдельные маленькие временные участки, для каждого такого участка устанавливается определенная величина интенсивности звука. таким образом, непрерывная зависимость громкости звука от времени a(t) заменяется на дискретную последовательность уровней громкости. на графике это выглядит как замена гладкой кривой на последовательность "ступенек" (рис. 1.2). рис. 1.2. временная дискретизация звука частота дискретизации. для записи аналогового звука и г го преобразования в цифровую форму используется микрофон, подключенный к звуковой плате. качество полученного цифрового звука зависит от количества измерений уровня громкости звука в единицу времени, т. е. частоты дискретизации. чем большее количество измерений производится за i секунду (чем больше частота дискретизации), тем точнее "лесенка" цифрового звукового сигнала повторяет кривую диалогового сигнала. частота дискретизации звука - это количество измерений громкости звука за одну секунду. частота дискретизации звука может лежать в диапазоне от 8000 до 48 000 измерений громкости звука за одну секунду. глубина кодирования звука. каждой "ступеньке" присваивается определенное значение уровня громкости звука. уровни громкости звука можно рассматривать как набор возможных состояний n, для кодирования которых необходимо определенное количество информации i, которое называется глубиной кодирования звука. глубина кодирования звука - это количество информации, которое необходимо для кодирования дискретных уровней громкости цифрового звука. если известна глубина кодирования, то количество уровней громкости цифрового звука можно рассчитать по формуле n = 2i. пусть глубина кодирования звука составляет 16 битов, тогда количество уровней громкости звука равно: n = 2i = 216 = 65 536. в процессе кодирования каждому уровню громкости звука присваивается свой 16-битовый двоичный код, наименьшему уровню звука будет соответствовать код 0000000000000000, а наибольшему - 1111111111111111. качество оцифрованного звука. чем больше частота и глубина дискретизации звука, тем более качественным будет звучание оцифрованного звука. самое низкое качество оцифрованного звука, соответствующее качеству телефонной связи, получается при частоте дискретизации 8000 раз в секунду, глубине дискретизации 8 битов и записи одной звуковой дорожки (режим "моно"). самое высокое качество оцифрованного звука, соответствующее качеству аудио-cd, достигается при частоте дискретизации 48 000 раз в секунду, глубине дискретизации 16 битов и записи двух звуковых дорожек (режим "стерео"). необходимо помнить, что чем выше качество цифрового звука, тем больше информационный объем звукового файла. можно оценить информационный объем цифрового стереозвукового файла длительностью звучания 1 секунда при среднем качестве звука (16 битов, 24 000 измерений в секунду). для этого глубину кодирования необходимо умножить на количество измерений в 1 секунду й умножить на 2 (стереозвук): 16 бит × 24 000 × 2 = 768 000 бит = 96 000 байт = 93,75 кбайт. звуковые редакторы. звуковые редакторы позволяют не только записывать и воспроизводить звук, но и редактировать его. оцифрованный звук представляется в звуковых редакторах в наглядной форме, поэтому операции копирования, перемещения и удаления частей звуковой дорожки можно легко осуществлять с мыши. кроме того, можно накладывать звуковые дорожки друг на друга (микшировать звуки) и применять различные акустические эффекты (эхо, воспроизведение в обратном направлении и

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисляющую выражения. z=(sqr(x+1)*(x-(18*x*y))
Ваше имя (никнейм)*
Email*
Комментарий*