Программа qbasic даны два целых числа a и b написать программу рассчитывающую и выводящую на экран значение суммы всех целых чисел от a до b и их количество
Input "a="; a input "b="; b for i = a to b s = s + i n = n + 1 next i print "сумма: "; s print "количество: "; n
zoosalon-hollywood5
03.05.2021
Const n=15; var a: array[1..n] of integer; i,s,k: integer; begin randomize; for i: =1 to n do begin a[i]: =random(21)-10; write(a[i]: 4); end; writeln; s: =0; k: =0; for i: =1 to n do if a[i]< 0 then a[i]: =0 else if a[i]> 0 then begin s: =s+a[i]; k: =k+1; end; for i: =1 to n do write(a[i]: 4); writeln; writeln('s=',s,' k=',k); end.пример: -8 -3 10 0 3 1 -10 8 4 -3 9 0 -10 -2 1 0 0 10 0 3 1 0 8 4 0 9 0 0 0 1s=36 k=7
ekkim310
03.05.2021
Const n=10; var a: array[1..n] of integer; i: integer; begin randomize; for i: =1 to n do begin a[i]: =random(21)-10; write(a[i]: 4); end; writeln; for i: =1 to n do if a[i]> 0 then a[i]: =2*a[i] else if a[i]< 0 then a[i]: =7; for i: =1 to n do write(a[i]: 4); writeln; end.пример: -4 4 -10 6 -8 9 0 5 3 10 7 8 7 12 7 18 0 10 6 20
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Программа qbasic даны два целых числа a и b написать программу рассчитывающую и выводящую на экран значение суммы всех целых чисел от a до b и их количество