Fedorova_79166180822
?>

Написать программу для отыскания max(min(a, b), min(c, не используя сложные логические условия и вложенные ветвления. числа a, b, c, d - целые. протестировать программу для следующих исходных данных: а) a=4 b=5 c=6 d=9 б) a=2 b=1 c=6 d=9 в) a=2 b=1 c=8 d=4 г) a=12 b=1 c=6 d=9

Информатика

Ответы

delena6467
Var a,b,c,d,m1,m2,max: integer; begin write('введите a,b,c,d: '); readln(a,b,c,d); if a< b then m1: =a else m1: =b; if c< d then m2: =c else m2: =d; if m1< m2 then max: =m2 else max: =m1; writeln('max=',max) end.
rusdtver
Какого редактора? ? напишу про пейнт

ластик/цветной ластик  – стирает часть рисунка при нажатии левой кнопки мыши или заменяет основной цвет на фоновый при нажатии правой.

  заливка  – заполняет цветом одноцветную область рисунка.

  выбор цвета  – определяет цвет фрагмента при выполнении на нем щелчка и устанавливает его в качестве основного или фонового цвета.

  масштаб  – увеличивает фрагмент рисунка.

  карандаш  – рисует как обычный карандаш при нажатой левой или правой кнопкой мыши.

  кисть  – используется как карандаш, но рисует более толстыми линиями, форма кисти может выбираться.

  распылитель  – распыляет краску при нажатой левой или правой кнопкой мыши.

  линия  – проводит прямую линию при нажатой левой кнопке мыши (удерживая клавишу  shift, можно получить линию строго вертикальную, горизонтальную линию или под углом 45o).

  кривая  – рисует прямую линию, которую затем можно изгибать 2 раза, отводя мышь в сторону от рисунка.

  прямоугольник  – создает прямоугольник или квадрат (удерживая  shift) путем протаскивания мыши с нажатой левой кнопкой.

  скругленный прямоугольник  – то же, что и прямоугольник, но углы скруглены.

  эллипс  – рисует овалы и круги (удерживая  shift).

  многоугольник  – для рисования многоугольника необходимо щелкать в каждой его вершине, а в последней – дважды.

subbotinlan
#include< iostream> #include< string> #include< locale> using namespace std; int main() {            setlocale(lc_ctype,"rus");       cout < < "ââåäèòå äâà ñëîâà ðàâíîé äëèíû: "< < "\n";       string x,y;       int k = 0;       cin > > x > > y;       for(int i = 0; i< =x.length(); i++)       {             k+=(x[i]! =y[i]);       }       cout < < k < < "\n";       return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для отыскания max(min(a, b), min(c, не используя сложные логические условия и вложенные ветвления. числа a, b, c, d - целые. протестировать программу для следующих исходных данных: а) a=4 b=5 c=6 d=9 б) a=2 b=1 c=6 d=9 в) a=2 b=1 c=8 d=4 г) a=12 b=1 c=6 d=9
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

picsell
xobby18
kolefe22171
tshelokova
andrewshilin1334
Владислав-Александр32
topshopnails
printlublino
Владислав-Александр32
voloshin238
Roman913
Shlapakov1911aa
karpov68
manu95957
arinaunknown6867