hristos1212
?>

Написать программу на языке pascal: : вводятся целые числа до первого числа, которое меньше двух. определить, сколько простых чисел было введено. описание переменных: q - счетчик простых чисел; n - очередное введенное число. алгоритм решения : пока введенное число больше 1, проверять его на простоту по следующему алгоритму: если число делится на любой делитель от 2 до половины от себя, то оно не простое. если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.

Информатика

Ответы

gbelihina
Var q,n,i,k,h: integer; begin readln(n); h: =1; while n> 1 do   begin   k: =n div 2;   for i: =2 to k do     if n mod i=0 then h: =0;   q: =q+h;   h: =1;   readln(n);   end; writeln('простых чисел: ',q) end.
egamedicalbuh
#include < iostream> #include < cstring> int main() { char* text1 = "слово"; char* text = "как то текст с гласными на конце кок"; char* newtext = new char[strlen(text)]; int laststop = 0, lastiter = 0; for (int i = 0; text[i] ! = '\0'; i++) { bool copyit = false; if (text[i] == ' ') laststop = i; if (text[i + 1] == ' ' || text[i + 1] == '\0') { for (int j = 0; text1[j] ! = '\0'; j++) { if (text[i] == text1[j]) { copyit = false; break; } copyit = true; } } if (copyit == true) { for (int j = laststop; j < = i; j++, lastiter++) newtext[lastiter] = text[j]; } } for (int i = 0; i < lastiter; i++) std: : cout < < newtext[i]; std: : cout < < "\n"; return 0; }
vgolentsova
// pascalabc.net 3.2, сборка 1483 от 14.06.2017 // внимание! если программа не работает, обновите версию! begin   write('количество строк и столбцов в массиве: ');   var (n,m): =readinteger2;   writeln('*** исходный массив [',n,',',m,'] ***');   var a: =matrrandom(n,m,-99,99);   a.println(4); writeln(4*a.colcount*'-');   var t: =a.elementswithindexes.where(x-> x[0] mod 5=0).take(1);   a.swaprows((t.first)[1],n-1);   writeln('*** результирующий массив ***'); a.println(4) end. пример количество строк и столбцов в массиве: 4 5 *** исходный массив [4,5] ***   -32 -12  94 -28 -42   -15  29  80  28 -69   -5  68  63 -12  22   59  84  65  14 -86 *** результирующий массив ***   -32 -12  94 -28 -42   59  84  65  14 -86   -5  68  63 -12  22   -15  29  80  28 -69

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке pascal: : вводятся целые числа до первого числа, которое меньше двух. определить, сколько простых чисел было введено. описание переменных: q - счетчик простых чисел; n - очередное введенное число. алгоритм решения : пока введенное число больше 1, проверять его на простоту по следующему алгоритму: если число делится на любой делитель от 2 до половины от себя, то оно не простое. если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Тинчурина1528
elena-ppk
tanyaandreeva728
braigon974
helenavalenti2846
trast45
Nazart44446
Makarov
oslopovavera
gulsinatahckeeva
fudan
сергей1246
tatry2005
Khrimyan1207
iracaenko153