Levinalx4938
?>

Составить программу , в среде pascal abc (turbo pascal) выполняющую вычисления по формуле: y=2ctg3x- распешите все действия что писать .

Информатика

Ответы

samsludmila
Паскаль авс: program ikiru; uses crt; var   y,x: real; begin   writeln('*** alphaeus is ***');   writeln('***                  ok                        ***');   writeln(); writeln();       write('введите х '); readln(x);       if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)< =0)           then               writeln('функция y для этого значения х не определена')           else               begin                   y: =2*(cos(3*x)/sin(3*(cos(x))/ln(1+x*x);                   writeln('y=',y: 8: 2);               end; end. пояснения: write('введите х '); readln(x);   - программа просит пользователя ввести х if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)< =0)   - проверка существования функции (функция ctgх не существует, если sinx=0, ln берется только от неотрицательных значений, в знаменателе дроби не может быть 0) если хотя бы одно из условий не выполняется,  выводится ссобщение о том, что функция для этого значения не определена. если все проверки пройдены, программа вычисляет значение функции y и выводит его на экран.
Ye.Vadim
12) var a: array[1..7] of integer; k: integer; begin randomize; for k : = 1 to 7 do a[k] : = random(5); write("vvedite den' nedeli: "); readln(k); if (k < 1 or k > 7) writeln("error"); else if ( a[k] < > 0) then writeln("segodnya urokov: ", a[k]); else write("vyhodnoy"); end. 13) var k: real; begin write("vvedite chislo: "); readln(k); if (k > 0) then write("polozhitel'noe, "); else if (k < 0) then write("otricatel'noe, "); else write("nol', "); if (k mod 1 < > 0) then write("neceloe, "); else write("celoe, "); if (k mod 2 < > 0) then writeln("nechetnoe"); else writeln("chetnoe"); end.
kyrtlab39
Не знаю, причем тут "понятность" - это субъективное понятие, сильно зависящее от уровня подготовки читающего текст программы. "точность" тоже под вопросом, поскольку большинство алгоритмов сами по себе не некоей абсолютной точностью, а программы - суть запись алгоритма на некоем языке, доступном компилятору. также, на мой взгляд, тут не перечислены некоторые иные важные свойства программы. но в наибольшей степени на ответ, который тут может считаться "правильным", претендует 4) однозначность, дискретность, точность, понятность, результативность, массовость. ответ: 4)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу , в среде pascal abc (turbo pascal) выполняющую вычисления по формуле: y=2ctg3x- распешите все действия что писать .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

drozd228758
Letajushaya362
dovgash2
mdclcompany
kifstd
falileevas
mtcover
Суховодова599
Shevtsov1818
POMILEVAVladimirovna269
akinin95
atlantika7
Татьяна902
diana-020
elenaftdv7