Var a,b,c: real; begin write('введите три числа'); read(a,b,c); a: = - a; b: = - b; c: = - c; writeln('ответ: ', a, ' ' , b, ' ', c); end.
infooem
12.04.2022
Var i,n,mn,mx: integer; a: array of integer; begin { считать количество чисел n } write('n = '); readln(n); { установить длину массива а n+1, массив динамический, нумерация с нуля} i: =1; setlength(a,n+1); writeln('введите числа через пробел: '); {циклический ввод n чисел с клавиатуры} repeat read(a[i]); i: =i+1; until i> n; { конец ввода } { начальные значения для максимума и минимума mn mx } mn: =a[1]; mx: =a[1]; { цикл по элементам массива } for i: =1 to n do begin { если элемент массива больше текущего максимума, то в максимум записать текущий элемент } if a[i]> mx then mx: =a[i]; { если элемент массива меньше текущего минимума, то в минимум записать текущий элемент } if a[i]< mn then mn: =a[i]; end; { конец цикла } writeln('min = ',mn,' max = ',mx); writeln('разница: (max - min) = ',mx-mn); end.
Татьяна_Полулях
12.04.2022
Сортировка временитребуется выполнить сортировку временных моментов, заданных в часах, минутах и секундах.входные данныево входном файле input.txt в первой строке записано число n (1< =n< =100), а в последующих n строках n моментов времени. каждый момент времени задается 3 целыми числами - часы (от 0 до 23), минуты (от 0 до 59) и секунды (от 0 до 59).выходные данныев выходной файл output.txt выведите моменты времени, в порядке неубывания без ведущих нулей.примерinput.txt 410 20 307 30 0023 59 5913 30 30 output.txt 7 30 010 20 3013 30 3023 59 59
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу в паскалях: даны 3 числа. вывести их на экран с противоположным знаком.