vera141187
?>

Решить (в паскале) дан массив из 20 элементов. найти количество четных и нечетных чисел в массиве

Информатика

Ответы

Mydariamiro
Var a: array[1..20] of integer; i,k1,k2: integer; begin for i: =1 to 20 do begin read(a[i]); if odd(a[i]) then k2+=1; if not odd(a[i]) then k1+=1; end; writeln(k1,' ',k2); end.
alfaduk24908
16. Найдите ответы на вопросы:Какая картинка используется для выбора цвета в модели HSB?

Место для ввода текста.

Как перевести код цвета из модели RGB в модель CMY?

Место для ввода текста.

Зачем используют цветовую модель Lab?

Место для ввода текста.

17. Найдите ответы на вопросы:

В каких форматах можно сохранить изображение с палитрой?

Место для ввода текста.

Определите размер палитры и глубину цвета при кодировании с палитрой 128 цветов:

глубина цвета битов на пиксель, размер палитры байтов.

Как можно преобразовать рисунок, записанный в формате истинного цвета, в формат с палитрой?

Место для ввода текста.

18. Найдите ответы на вопросы:

Cколько цветов может быть в палитре файлов форматов BMP, GIF, PNG?

От до .

Какие форматы файлов могут хранить анимированные изображения?

Место для ввода текста.

C каких символов начинаются файлы в формате JPEG?

Место для ввода текста.

19. Рисунок размером 10×15 см кодируется с разрешением 300 ppi. Оцените количество пикселей в этом рисунке.

Ширина = пикселей.

Высота = пикселей.

Всего = пикселей.

20. Какова глубина цвета, если в рисунке используется

65536 цветов: битов 256 цветов: битов

212 цветов: битов 27 цветов: битов

16 цветов: битов 4 цвета: битов

21. Сколько байтов будет занимать код рисунка размером 40×50 пикселей в режиме истинного цвета:

Место для ввода текста.

при кодировании с глубиной цвета 8 битов на пиксель:

Место для ввода текста.

при кодировании с глубиной цвета 4 бита на пиксель:

Место для ввода текста.

в черно-белом варианте (два цвета):

Место для ввода текста.

22. Постройте двоичные коды для двухцветных рисунков и запишите их в шестнадцатеричной системе счисления. Обозначайте белые пиксели кодом 1, а чёрные – кодом 0. Выделите фоном группы по 4 бита, которые объединяются в одну шестнадцатеричную цифру.

Какие сложности у вас возникли?

Место для ввода текста.

Как их можно преодолеть?

Место для ввода текста.

23. Постройте черно-белый рисунок шириной 8 пикселей, закодированный шестнадцатеричной последовательностью 2466FF662416. Белые пиксели имеют код 1, чёрные – код 0.

24. Постройте черно-белый рисунок шириной 5 пикселей, закодированный шестнадцатеричной последовательностью 3A53F8816. Белые пиксели имеют код 1, чёрные – код 0.

25. Для жёлтого цвета найдите красную, зеленую и синюю составляющие при 12-битном кодировании (4 бита на канал, 4096 цветов):

R = G = B =

26. Иногда используют 16-битное кодирование цвета (англ. High Color), при котором на красную и синюю составляющую отводится по 5 бит, а на зеленую, к которой человеческий глаз более чувствителен, – 6 бит.

Сколько различных цветов можно закодировать таким образом?

Место для ввода текста.

Определите числовые значения яркостей каждого канала для жёлтого цвета: R = G = B =

27. Сколько места занимает палитра в файле, где используются

64 цвета: = байтов.

128 цветов: = байтов.

N цветов: байтов.

28. Сколько байтов будет занимать код рисунка размером 80×100 пикселей при кодировании с глубиной цвета 12 битов на пиксель?

= байтов.

при кодировании с глубиной цвета N бит на пиксель?

= байтов.

29. Для хранения растрового изображения размером 32×32 пикселя выделено 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения?

Глубина цвета:

Место для ввода текста.

Количество цветов:

Место для ввода текста.

30. Для хранения растрового изображения размером 128128 пикселей выделено 4 килобайта памяти. Каково максимально возможное число цветов в палитре изображения?

Место для ввода текста.

31. При обработке растрового графического файла количество цветов уменьшилось с 256 до 16. Во сколько раз уменьшился размер файла?

32. При обработке растрового графического файла количество цветов уменьшилось с 64 до 4. Во сколько раз уменьшился объём файла?

33. Разрешение экрана монитора – 1024×768 точек, глубина цвета – 16 битов на пиксель. Какой объём памяти (в Мбайтах) требуется для хранения полноэкранного изображения экрана в данном графическом режиме?

Место для ввода текста.

Объяснение:

вот тебе твой вопрос..

за хахаха
Maksim Lokhov

10. Нам нужно удовлетворить условие

1000 < 4^x

Методом "великого тыка" берем x = 4.

4^4 = 256

256 < 1000

Не подходит. x + 1 = 5

4^5 = 1024

1024 > 1000 - Подходит

Следовательно, Ваше наименьшее k = 5

12. 00000- пустое множество

т.к. все нули, то множество будет пустым

01110- {3,5,7}

т.к. на 2,3,4 местах присутствует 1, то подмножество будет {3,5,7}

00111- {5,7,9}

т.к. на 3,4,5 местах присутствует 1, то подмножество будет {5,7,9}

11111- {1,3,5,7,9,}

т.к. везде присутствует 1, то подмножество будет {1,3,5,7,9}

у множества М может быть 32 различных подмножеств

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить (в паскале) дан массив из 20 элементов. найти количество четных и нечетных чисел в массиве
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Lapushkina
Полковников_Милана
zibuxin6
борисовна Елена78
rusplatok
pravovoimeridian
zrv85
dmitrievanata83538
Vos-sv
Rafigovich1267
Lugovoi
kristina1989
Shtorm-Shoe
alexandergulyamov
kabinet17