iservice38
?>

Напишите программу определяющую лежит ли точка а (xa, ya )на прямой y=kx+l, на ней, под ней или над ней.

Информатика

Ответы

Yevgenii1423
Петруха сама пиши! а ты 13 решила можеш прислать программу program pryamay; var xa,ya,k,l: real; begin; if(k,l> -1+5)or(xa,ya> 1+2)then write('точка лежит под прямой') if(k,l> -1+5)or(xa,ya> 1+10)then write ('точка лежит над прямой') if(k,l> -1+5)or(xa,ya> 1+4) then write ('точка лежит на прямой') end.это 10
Yumashev
Fистинно тогда и только тогда, когда истинно или , или z. три переменные (x,y,z) 2³=8 комбинаций в таблице истинности. при этом, истинность f получается в пяти случаях (четыре дает истинность z и одну - истинность ). получаем пять единичных комбинаций для таблицы истинности: x  y z f 0 0 1 1 0 1 1 1 1 0 0 1 1 0 1 1 1 1 1 1 в исходной таблице истинности единицы в f в четырех случаях с единицами в первой колонке, следовательно она отражает состояние переменной z. оставшаяся (пятая) единица в f должна соответствовать комбинации "100" для xyz и в исходной таблице она записана как "010". тогда переменная х=1 должна стоять в этой таблице во второй колонке. колонка для у - третья. ответ: zxy
I.B.Petrishchev
Const   a=5.1;   x=3.29; var   y,z: double; begin   y: =2*exp(4*x)+arctan(x/a);   z: =cos(x*sqr(x))+sqr(sin(x));   writeln('y=',y,', z=',z) end. результат выполнения программы: y=1038354.42291114, z=-0.472433980670957 const   m=6;   n=8; var   a: array[1..m,1..n] of double;   b: array[1..m*n] of double;   i,j,k,imax,imin: integer;   t: double; begin   // инициализация а и формирование в   randomize;   writeln('исходный массив a');   k: =0;   for i: =1 to m do begin       for j: =1 to n do begin           a[i,j]: =10*random-5; { случайное число на [-5; 5] }           write(a[i,j]: 8: 4);           t: =cos(a[i,j]);           if (t> =0) and (t< 0.5) then begin inc(k); b[k]: =a[i,j] end       end;       writeln   end;   // вывод сформированного массива в   writeln('исходный массив в');   for i: =1 to k do write(b[i]: 8: 4);   writeln;   // поиск максимума и минимума с последующим обменом их местами   imax: =1; imin: =1;   for i: =2 to k do       if b[i]< b[imin] then imin: =i       else           if b[i]> b[imax] then imax: =i;   t: =b[imax]; b[imax]: =b[imin]; b[imin]: =t;   // вывод результирующего массива в   writeln('результирующий массив в');   for i: =1 to k do write(b[i]: 8: 4);   writeln end. тестовое решение: исходный массив a   -1.6788 -0.7273 -3.4919  2.9903 -4.3249 -2.2230 -2.1157  0.9685   2.0515  4.6821  0.2794 -1.4624  4.9668 -3.5754 -3.4115 -0.5592   3.0535  1.1339  0.0992 -0.5307 -0.6266  2.2623  1.9578 -1.3175   -0.6154  3.6080  2.4223 -4.8354 -2.2978  3.8982 -2.2427  2.0410   -1.1019 -3.4703 -2.0104 -1.3044  0.7744  0.6897  3.1747  1.3257   -4.3942 -1.6707 -3.2494 -0.6551  3.4726 -0.2896  3.4154  1.9644 исходный массив в   -1.4624  4.9668  1.1339 -1.3175 -4.8354 -1.1019 -1.3044  1.3257 результирующий массив в   -1.4624 -4.8354  1.1339 -1.3175  4.9668 -1.1019 -1.3044  1.3257

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу определяющую лежит ли точка а (xa, ya )на прямой y=kx+l, на ней, под ней или над ней.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

com4047797
Руслан1360
Seid-ZadeNadezhda1769
tyrnaus
Vetroff-11
Nadegdasb
k075ko8
rinata542
tanyashevvvv
ars-trushakova
alekseev13602
Борисовна_Кашутина
Anton-Yurevich222
OlgaVasilevna
Ofelya1308
▲