nikolai37
?>

Составить программу, которая создает и выводит на экран массив такого вида: 0000000 1000001 1100011 1110111 1100011 1000001 0000000

Информатика

Ответы

stertumasova29
Program asd; uses crt; const n=7; var a: array [1..n,1..n] of integer; i,j,q,w: integer; begin  for i: =1 to n do    begin    for j: =1 to n do      begin    if((j< i)and(j< n-i+1))or((j> n-i+1)and(j> i)) then a[i,j]: =1      else a[i,j]: =0;       write(a[i,j]);   end;   writeln  end; end.интересное ) заставило подумать
fucingprinces30
1) дискретность - алгоритм должен состоять из отдельных пунктов. 2) понятность - каждая команда должна быть понятна исполнителю. 3) результативность - алгоритм должен приводить к заранее продуманному результату. 4) массовость - он должен решать не одну , а круг таких . 5) определенность - не должно быть команд, которые исполнитель воспримит неоднозначно. н-р: 1) 1. повернуть направо.     2. пройти 2 шага.     3. повернуть налево. 2) не должно быть таких команд:     1. пройти 2 шага       2. зачикиниться3) к примеру, рецепт бутерброда тебя к готовому бутеру (если, конечно, ты поборишь свою лень и встанешь, чтобы приготовить его) 4) н-р, формула расчета притяжения между телами должна быть ориентирована на различные тела, а не на, к примеру, только землю и луну. 5) не должно быть, н-р, таких команд:   1. повернуть направо   2. пройти 2 шага     3. украсть.   4. пройти 2 шага назад.     5. дойти до машки с пятого подъезда.  автор:   macint
pokupatel688
// pascalabc.net 3.2, сборка 1379 от 21.01.2017 // внимание! если программа не работает, обновите версию! begin   var a: =arrrandom(200,20,80); a.println;   writeln('ср.арифм: ',a.average: 0: 3);   writeln('ср.арифм. элементов, меньших 50: ',a.where(x-> x< 50).average: 0: 3);   var m: =a.min;   a.replace(m,0);   a.println end. пример 55 24 28 58 53 69 59 34 39 31 43 37 54 67 53 55 69 39 55 79 24 49 38 51 35 45 51 72 71 55 20 29 67 37 48 33 66 55 54 77 58 58 30 38 20 52 48 39 47 77 75 24 55 63 77 25 67 58 42 28 38 68 43 64 31 34 50 36 39 39 70 34 65 58 41 46 39 80 50 64 78 31 45 75 61 76 55 24 41 42 47 28 32 46 59 71 35 46 26 67 21 31 80 27 27 61 39 77 42 50 66 68 27 59 30 26 42 49 23 35 60 46 76 78 73 61 21 38 80 50 31 74 73 63 62 67 32 37 68 20 57 58 62 72 56 59 20 54 35 53 48 66 43 71 27 55 36 22 35 46 60 20 78 72 39 73 75 45 77 44 75 25 61 23 59 21 64 24 41 33 61 47 23 46 22 45 51 22 55 26 51 29 22 42 41 56 60 71 52 64 ср.арифм: 48.965 ср.арифм. элементов, меньших 50: 34.386 55 24 28 58 53 69 59 34 39 31 43 37 54 67 53 55 69 39 55 79 24 49 38 51 35 45 51 72 71 55 0 29 67 37 48 33 66 55 54 77 58 58 30 38 0 52 48 39 47 77 75 24 55 63 77 25 67 58 42 28 38 68 43 64 31 34 50 36 39 39 70 34 65 58 41 46 39 80 50 64 78 31 45 75 61 76 55 24 41 42 47 28 32 46 59 71 35 46 26 67 21 31 80 27 27 61 39 77 42 50 66 68 27 59 30 26 42 49 23 35 60 46 76 78 73 61 21 38 80 50 31 74 73 63 62 67 32 37 68 0 57 58 62 72 56 59 0 54 35 53 48 66 43 71 27 55 36 22 35 46 60 0 78 72 39 73 75 45 77 44 75 25 61 23 59 21 64 24 41 33 61 47 23 46 22 45 51 22 55 26 51 29 22 42 41 56 60 71 52 64

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая создает и выводит на экран массив такого вида: 0000000 1000001 1100011 1110111 1100011 1000001 0000000
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ИринаАлександровна
rikki07834591
oalexandrova75
scorpion21c
BelozerovaGeller648
Ruslanovich1217
morozova
irinaastapova2011
Nadezhda
tvshi
smirnovaL1286
Потапова 79275136869323
Тинчурина1528
kulturarai44
ViktorovnaKraeva634