Kochereva-Sergei
?>

Составьте программу нахождения среднего арифметического всех элементов матрицы в размере 8*8

Информатика

Ответы

sonicegle
Выше решение не для матрицы 8х8, а для одномерного массива из 5-ти элементов. вот для двухмерной матрицы 8х8: const n=8; var a: array[1..n,1..n] of integer; i,j,s: integer;   sr: real; begin for i: =1 to n do for j: =1 to n do a[i,j]: =random(50)-20; for i: =1 to n do begin for j: =1 to n do write(a[i,j]: 4); writeln; end; writeln; sr: =0; s: =0; for i: =1 to n do for j: =1 to n do s: =s+a[i,j]; sr: =s/sqr(n); write('среднее арифметическое всех элементов матрицы =  ',sr); end.
archala

Стоит отметить, что задача не "на списки", и, фактически, решается без них эффективнее.

def get_divcount(n):

   divcount = 0

   for number in range(2, n // 2 + 1):

       if not n % number:

           divcount += 1

   return divcount

max_number, max_divcount = 0, 0

# range -- работает только для Z (множества целых чисел)

# поэтому верно следующее:

# range(a, b) <=> [a, b)

# range(a, b + 1) <=> [a, b]

for number in range(84052, 84130 + 1):

   divcount = get_divcount(number)

   if divcount > max_divcount:

       max_number, max_divcount = number, divcount

print("Делители:", max_divcount)

print("Число:", max_number)

TrubnikovKlimenok926

1)

N = int(input())

K = int(input())

L = int(input())

a = []

s = 0

for i in range(N):

   a.append(int(input()))

for i in range(K,L+1):

   s += a[i]

print(s)

2)

N = int(input())

K = int(input())

L = int(input())

a = []

s = 0

counter = 0

for i in range(N):

   a.append(int(input()))

for i in range(K,L):

   s += a[i]

   counter+=1

print(s/counter)

3)

N = int(input())

k = int(input())

L = int(input())

a = []

s = 0

for i in range(N):

   a.append(int(input()))

for i in range(0,k):

   s+=a[i]

for i in range(L+1,N+1):

   s+=a[i]

print(s)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу нахождения среднего арифметического всех элементов матрицы в размере 8*8
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yuliya Aleksandr282
Nefedova1432
nchorich55
contact
Анна1169
Владимир-Денисович1080
Как можно кодировать информацию​
Yelena642
eugene869154
sv-opt0076
Александрович Алексеевна
filantropagv4
Lusiarko65
Pogosyan Nataliya
Ubuleeva826
lbondareva