kuliba
?>

Составьте программу, вычисляющую для двух дробей a/b и c/d (a, b, c, d - натуральные числа): деление умножение сложение. результат представить в виде простых несократимых дробей в виде функции. pascal

Информатика

Ответы

Aleksandrovna1153
Как-то так) var a,b,c,d,e,f: integer; function nod(m,n: integer): integer; begin while m< > n do if m> n then m: =m-n         else n: =n-m; nod: =m end; begin write('введите числитель1, знаменатель1, числитель2, знаменатель2'); readln(a,b,c,d); e: =a*d+b*c; f: =b*d;   if f=0 then write('на 0 делить нельзя') else if e=0 then writeln('сложение =    ',e)        else begin         e: =e div nod(abs(e),f);           f: =f div nod(abs(e),f);           writeln('сложение =  ',e,'\',f);           end; e: =a*c; f: =b*d;   if f=0 then write('на 0 делить нельзя') else if e=0 then writeln('умножение =  ',e) else begin   e: =e div nod(abs(e),f);         f: =f div nod(abs(e),f);         writeln('умножение =  ',e,'\',f);           end; e: =a*d; f: =b*c; if f=0 then write('на 0 делить нельзя') else           if e=0 then writeln('деление=    ',e) else begin  e: =e div nod(abs(e),f);         f: =f div nod(abs(e),f);         writeln('деление =  ',e,'\',f);           end;         end.
Irina_Nikolai
Program mas; var i,b: integer;       a: array [1..n] of integer; begin   b: =0   for i: =1 to n do begin                           a[i]: =random(4,5);                           write(a[i],' ');                           b: =b+a[i];                           end;   writeln;   write('сумма всех элементов равна= ',b); end.
Veronika343
Можно создать хоть какие..

по способу исполнения  программы делят на

интерпретируемыекомпилируемые.

по степени переносимости  программы делят на

платформозависимыекроссплатформенные.

по способу распространения и использования  программы делят на

несвободные (закрытые); открытыесвободные.

по назначению  программы делят на[15]:

системные;   прикладные  и  инструментальные. 

по   программы делят на[16]:

компонент: программа, рассматриваемая как единое целое, выполняющая законченную функцию и применяемая самостоятельно или в составе комплекса; комплекс: программа, состоящая из двух или более компонентов и (или) комплексов, выполняющих взаимосвязанные функции, и применяемая самостоятельно или в составе другого комплекса.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, вычисляющую для двух дробей a/b и c/d (a, b, c, d - натуральные числа): деление умножение сложение. результат представить в виде простых несократимых дробей в виде функции. pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zabava-83
dpodstrel85
Nastyaches4
Nazaruk_Kodochigov
Анатольевич Сергей7
sargisyan
nadjasokolova2017
Даниил247
shchepinasm
murin
legezin
Alekseevna1811
nikziam
aninepp
Vyacheslavovich-Gubanov
▲