fox-cab3444
?>

Нужно написать код к программе на языке с. создать файл, содержащий информацию о результатах спортивных соревнований. структура записи: вид спорта, фамилия участника, номер группы, количество набранных участником . составить программу, которая выдает следующую информацию: - общее количество , набранных студентами каждой группы с определением группы победителя; - фамилии участников по указанному виду спорта; - фамилии победителей по отдельным спорта (1, 2, 3 - место​

Информатика

Ответы

olgalooo
Var   n, i, j, askthemountains: longint;   a: array of longint;   fl: text; begin   assign(fl, 'input.txt');   reset(fl);   readln(fl, n);   setlength(a, n);   for i : = 0 to (n - 1) do     readln(fl, a[i]);   close(fl);   assign(fl, 'output.txt');   rewrite(fl);       for i : = 0 to n - 1 do     for j : = i to n - 1 do       if (a[i] > a[j]) then       begin         askthemountains : = a[i];         a[i] : = a[j];         a[j] : = askthemountains;       end;   for i : = 0 to n-1 do     writeln(fl, a[i]);   close(fl); end.
shalunovroman
Type   tmatrix = array[,] of integer;   tvector = array of integer; var    a: tmatrix;   b: tvector;   m,n,i,j: integer;     procedure createmulvector(a: tmatrix; var b: tvector); var i, j: integer; f: boolean; begin   setlength(b, length(a, 0));   for i : = 0 to length(a, 0) - 1 do begin     b[i] : = 1; f : = false;     for j : = 0 to length(a, 1) - 1 do begin       if a[i,j] > 0 then begin         f : = true;         b[i] : = b[i] * a[i,j];       end;     end;     if not f then b[i] : = 0;   end; end; procedure writevector(b: tvector); var i: integer; begin   for i : = 0 to length(b) - 1 do      write(b[i]: 3); end; begin   randomize;   n : = random(10) + 1;   m : = random(10) + 1;   setlength(a, n, m);   writeln('исходная матрица: ');   for i : = 0 to n-1 do begin     for j : = 0 to m-1 do begin       a[i,j] : = random(10) - 5;         write(a[i,j]: 4);     end;     writeln;   end;       createmulvector(a, b);   writeln('полученный вектор: ');   writevector(b); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать код к программе на языке с. создать файл, содержащий информацию о результатах спортивных соревнований. структура записи: вид спорта, фамилия участника, номер группы, количество набранных участником . составить программу, которая выдает следующую информацию: - общее количество , набранных студентами каждой группы с определением группы победителя; - фамилии участников по указанному виду спорта; - фамилии победителей по отдельным спорта (1, 2, 3 - место​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shoora
smirnovaL1286
Darialaza
oliayur4encko
i7aster26
Tuzov
marketing601
deshkina82
vladimirkirv
Yekaterina_Popova1413
Радецкая264
xalina85
Ольга1520
yamalsva45
Мунировна
▲