sveremeev816
?>

Паскаль составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

Информатика

Ответы

aidapiltoyan43

var

  a: array [1..10] of integer; //инициализируем массив из 10 целых чисел

  i: integer;

begin

  for i: = 1 to 10 do

  begin

    a[i]: = random(19) + 1; //заполняем массив случайными числами от 1 до 20

    if a[i] mod 2 = 1 then write(a[i], '   '); {если очередной элемент массива нечетный, то он выводится}

  end;

end.

Узлиян Фурсов1488
Разберем по порядку. итак: 1 проход цикла: (а < =8)? да. k: =k+1 --> k=2; a: =a+2 -->   a=2 2 проход цикла: (а < =8)? да. k: =k+1 --> k=3; a: =a+2 -->   a=4 3 проход цикла: (а < =8)? да. k: =k+1 --> k=4; a: =a+2 -->   a=6 4 проход цикла: (а < =8)? да. k: =k+1 --> k=5; a: =a+2 -->   a=8 5 проход цикла: (а < =8)? да! k: =k+1 --> k=6; a: =a+2 -->   a=10 6 проход цикла: (а < =8)? нет.. выход из цикла. в результате, переменная k=6.
Головин662
Const   dm: array[1..12] of integer=(31,28,31,30,31,30,31,31,30,31,30,31); var   d,m,y,dfeb: integer; begin   write('введите дату в формате день месяц год: ');   read(d,m,y);   if (m=2) and (d> =28) then begin       if ((y mod 4=0) and (y mod 100 < > 0)) or           ((y mod 100=0) and (y mod 400 =0)) then dfeb: =29       else dfeb: =29;       if d=dfeb then begin d: =1; inc(m) end       else inc(d);       if m=13 then begin m: =1; inc(y) end   end   else begin       inc(d);       if d> dm[m] then begin d: =1; inc(m) end;       if m=13 then begin m: =1; inc(y) end   end;   writeln('следующая дата ',d,' ',m,' ',y) end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Evsevia-a
ivan-chay19
strelnikov-aa
Кристина Валентиновна
Скворцов
beaevgen711
fedorenkoroman
BrezhnevaKoidula
yastrik
АлександрАлександровна
klimenokvapeshop1408
впвыпвып-Зуйков629
andreyshulgin835
compm
maksimovskiy7657