Андрееевич787
?>

За решение 4 студент получил оценки (от 1 до5) составьте программу, которая определит среднее значение оценок, полученных студентом за ! решите в ! 8

Информатика

Ответы

helena-belozerova
Var i,x: integer; sr: real; begin sr: =0; for i: =1 to 4 do begin write('оценка за №',i,' '); readln(x); sr: =sr+x; end; sr: =sr/4; write('средняя оценка ',round(sr)); end.
LidiyaBorzikh
Для перевода в двоичную систему делим число на 2 и записываем остатки от деления  285/2=142 остаток 1 142/2=71 остаток 0 71/2=35 остаток 1 35/2=17 остаток 1 17/2=8 остаток 1 8/2=4 остаток 0 4/2=2 остаток 0 2/2=1 остаток 0 1/2=0 остаток 1 записываем остатки снизу вверх 285₁₀=100011101₂ для перевода десятичного числа в восьмеричную систему счисления    проделываем те же операции, только делим на 8 285/8=35 остаток 5 35/8=4 остаток 3 4/8=0 остаток 4 записываем ответ снизу вверх 285₁₀=345₈ для перевода десятичного числа в шестнадцатеричную систему делим соответственно на 16 285/16=17 остаток 13, что в шестнадцатеричной системе соответствует букве d 17/16=1 остаток 1 1/16=0 остаток 1 ответ 285₁₀=   11d₁₆
pak1998378
Есть такая формула n=2^i, где n кол во символов в алфавите, а i кол во информации занимаемое одним символом. тогда если в алфавите 16 символов то 16=2^4 и следовательно каждый символ кодируется 4 битами. дальше находим объём сообщения, я просто посчитал на калькуляторе: 3: 16=0,1875( кбайт) в одном кбайте 1024 байт тогда 0,1875*1024=192(байт) в одном байте 8 бит тогда 192*8=1536(бит). и последнее определить сколько символов по 4 бита поместится в сообщение размером 1536 бит; 1536: 4=384 символа

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

За решение 4 студент получил оценки (от 1 до5) составьте программу, которая определит среднее значение оценок, полученных студентом за ! решите в ! 8
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nikomuneskazhu60
whiskyandcola
Salkinserg
Voronina747
mospaskrasnogorbukh
arhangel1055
zubritskiy550
Nikolaevna382
irschacha
Arutyunovich
alex091177443
balabinatanya7174
sargisyan
Светлана-Тигран
zsa100
▲