МихайловнаLarisa1150
?>

Составить блок-схему на языке паскаль. двумерный массив l задан при генератора случайных чисел из интервала [+1, +5]. подсчитайте произведение элементов данного массива, которые больше 10, но меньше 30

Информатика

Ответы

АркадьевичБундин789
Составить блок-схему на языке паскаль.-как понять? ? наверно написать программу?
upmoskovskiy
1. современное решение // pascalabc.net 3.2, сборка 1437 от 03.05.2017 // внимание! если программа не работает, обновите версию! begin   var a: =arrrandom(readinteger('n=',50); a.println;   var min: =a.min;   a.transform(x-> x< 0? x*min: x); a.println end. пример n= 15 -34 7 0 -48 4 42 35 14 -47 6 -29 43 46 40 -18 1632 7 0 2304 4 42 35 14 2256 6 1392 43 46 40 864 2. популярное до сих пор в школах решение на turbopascal 7.01 (1983г.) uses crt; const   nn=100; var   i,n,min: integer;   a: array[1..nn] of integer; begin   clrscr;   randomize;   write('n='); read(n);   min: =100;   for i: =1 to n do begin       a[i]: =random(101)-50;       write(a[i],' ');       if a[i]< min then min: =a[i]       end;   writeln;   for i: =1 to n do       if a[i]< 0 then a[i]: =a[i]*min;   for i: =1 to n do       write(a[i],' ');   writeln;   readkey end.
koxhulya61

культурный уровень современного человека определяется его информационной культурой. а информационная культура личности, как культура вообще, отражает активную творческую деятельность человека и, следовательно, развитие самого человека, как субъекта этой деятельности. так как речь идет о культуре информационной, значит деятельность человека связана с информацией. то есть, информационная культура предполагает не только определенные знания, но и определенное приложение этих знаний для чего-либо, в связи с чем-либо, и совершенствование их в процессе той или иной деятельности, в том числе деятельности, связанной с информацией. причем само приложение и совершенствование знаний значимо лишь в творчестве, реализованном в любой сфере жизнедеятельности человека.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить блок-схему на языке паскаль. двумерный массив l задан при генератора случайных чисел из интервала [+1, +5]. подсчитайте произведение элементов данного массива, которые больше 10, но меньше 30
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

svetegal
natasham-716
marinamarinyuk39
Vyacheslavovna
Ромеовна1527
misspodvigina
corneewa20096
Vladstreletskiy
mirogall
ekaterinaorl1998
dmitrymakarov003
khar4550
yocrew13
kattarina71
Aleksandr362