mzubenko6
?>

119) укажите наименьшее трёхзначное натуральное число, при вводе которого эта программа напечатает сначала 2, потом – 9. var x, a, b: longint; begin readln(x); a : = 0; b : = 1; while x > 0 do begin if x mod 2 > 0 then a : = a + 1 else b : = b + (x mod 5); x : = x div 5; end; writeln(a); write(b); end. объясните,

Информатика

Ответы

Баранов955
Предположим, что это две разные . окей. 1. var x : real; beginreadln(x); if (x< =4) and (x> =0) thenwriteln('число принадлежит интервалу от 0 до 4')elsewriteln('число не принадлежит интервалу от 0 до 4'); readln(x); end.   // readln в конце можно не писать, это делается для того, чтобы           //программа остановилась и можно было посмотреть результат! 2. var x : longint; beginreadln(x); if (x mod 5 = 0) thenwriteln('число делится на 5! ')elsewriteln('число не делится на 5! '); if (x mod 10 = 0) thenwriteln('число делится на 10! ')elsewriteln('число не делится на 10! '); readln(x); end.               // тут с readln та же фигня  
Сороченкова-Александр
1. короткий вариант // pascalabc.net 3.1, сборка 1230 от 27.04.2016 begin   var a: =arrrandom(10,10,20); a.println;   writeln('сумма кубов ',a.select(x-> x*x*x).sum);   a.transform(x-> x-5); a.println end. тестовое решение 14 17 12 17 20 11 13 18 19 20 сумма кубов 46517 9 12 7 12 15 6 8 13 14 15 2. "школьный вариант" // pascalabc.net 3.1, сборка 1230 от 27.04.2016 var   a: array[1..10] of integer;   i,s: integer; begin   randomize;   s: =0;   for i: =1 to 10 do begin       a[i]: =random(11)+10;       write(a[i],' ');       s: =s+a[i]*sqr(a[i])       end;   writeln;   writeln('сумма кубов ',s);   for i: =1 to 10 do begin       a[i]: =a[i]-5;       write(a[i],' ')       end;   writeln end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

119) укажите наименьшее трёхзначное натуральное число, при вводе которого эта программа напечатает сначала 2, потом – 9. var x, a, b: longint; begin readln(x); a : = 0; b : = 1; while x > 0 do begin if x mod 2 > 0 then a : = a + 1 else b : = b + (x mod 5); x : = x div 5; end; writeln(a); write(b); end. объясните,
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aaazovcev
yfetyukov
ВладимировнаАлександр1421
Nikita
snow8646
treneva359
ocik1632933
gr1schinanata
Вагифович
nikitavertiev98400
kapriz1999
annaar497
Anna-Miron
Александр734
stairov536
▲