info7
?>

4. студентам была предложена анкета о том, знание каких из прочитанных курсов могут потребоваться в будущей работе. результаты анкетирования были занесены в файл. напишите программу создания файла анкетирования. список прочитанных курсов: анализ; и ; информатика; ; философия.

Информатика

Ответы

slazurnaya
Const c1=' анализ'; c2=' и '; c3='информатика'; c4=''; c5='философия'; var   o: text; begin   assignfile(o, 'output.dat');   rewrite(o);   write(o,c1,'|',c2,'|',c3,'|',c4,'|',c5);           closefile(o) end.
Суханова1532

1) для кодирования одного из 16 символов необходимо log(2)16 = 4 бита (2^4=16); для кодирования одного из 32 символов необходимо log(2)32 = 5 бит (2^5=32). объем 1-го письма = 4*120 бит = 480 бит; объем второго - 5*96 = 480 бит. таким образом, объемы равны.

2) 375 байт = 375*8 бит = 3000 бит. объем одного символа = 3000/500 = 6 бит. мощность алфавита = 2^6 = 64 символа.

3) для кодирования одного из 64 символов необходимо log(2)64 = 6 бит. количество символов в тексте = 3*40*60. информационный объем текста = 3*40*60*6 бит = 3*40*60*6/8 байт = 5400 байт.

4) количество символов в указанном диапазоне = 311-55 = 256. количество информации в сообщении об одном числе диапазона = log(2)256 = 8 бит = 1 байт (2^8=256).

fafina12586

введение предложенное методическое пособие предназначено для организации работы по теме “моделирование” в рамках дисциплины “информационные технологии” для специальности 230103. оно включает в себя теоретические основы по основным разделам данной темы. содержит для самостоятельной работы студентов на уроке с целью закрепления полученных теоретических знаний. при выполнении практических работ доля самостоятельной деятельности студентов должна быть существенно выше, чем при других видах учебной работы; преподаватель в этой ситуации достаточно часто выступает в роли консультанта. это будущему специалисту научиться самостоятельно осваивать новые знания и умения, что является одной из важнейших целей обучения.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

4. студентам была предложена анкета о том, знание каких из прочитанных курсов могут потребоваться в будущей работе. результаты анкетирования были занесены в файл. напишите программу создания файла анкетирования. список прочитанных курсов: анализ; и ; информатика; ; философия.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oknacrow
Savva1779
mary---jane49
yuraotradnov
travkinadjey31
X2755070
Kornilova
valerii-borisovich550
fil-vasilij90
atlantika7
Равилевич_Олеговна1496
olechka197835
ambstroy
Larisa-Andrei
sidorov9