bergamon
?>

Кто с решением, буду . составьте программу, которая вводит с клавиатуры три целых числа: a, b, c (каждое число - с новой строки) и выводит на экран минимальное из них. ничего, кроме этого числа программа выводить не должна.

Информатика

Ответы

Vladmouse32506

program asd; uses crt; var a,b,c: integer; begin writeln('введите 3 числа'); readln(a); readln(b); readln(c);

if (a< b) and (a< c) then begin writeln('минимальное ', a); end else begin if (b< c) then writeln('минимальное ', b) else writeln('минимальное ', c); end;

end.

А Дзукаев1562
Во-первых, ты плохо расслышал условие. вместо "нестарого" файла должно быть "растрового" файла. растровый файл, в отличие от векторного - это файл, в котором каждый пиксел описывается отдельно, палитрой цветов. картинка имеет размер 1024*512 пикселей. если бы каждый пиксель занимал 1 байт, тогда размер файла был бы 1024*512 байт = 512 кбайт = 0,5 мбайта а у нас размер файла 1,5 мбайта, то есть в 3 раза больше. значит, каждый пиксел занимает 3 байта = 3*8 = 24 бита. эта глубина цвета называется true color и дает 2^24 = 16777216 цветов в палитре.
lshimina65
Xувеличивается в цикле с 1 до 4, каждый раз на 1. y каждый раз увеличивается в 2 раза, начиная с 1 и до 2^4 = 16. 1) тело цикла исполнится 4 раза. 2) x примет значение 5. 3) y примет значение 16. 4) если написать x < = 5, то тело цикла исполнится 5 раз. на выходе будет x = 6, y = 32. 5) если написать x > = 5, то тело цикла не будет исполнено ни разу, потому что условие сразу не выполняется. 6) если написать x > 0, то программа зациклится. цикл будет исполняться бесконечно, потому что x всегда > 0. 7) если убрать команду x: =x+1, то программа тоже зациклится. выхода не будет, потому что x всегда остается равным 1 < 5. 8) если написать команду x: =x+2, то тело цикла исполнится 2 раза: при x : = 1 и при x : = 3. на третий раз станет x = 5 и будет выход из цикла. 9) если написать команду x: =x-1, то программа зациклится. выхода не будет, потому что x будет уменьшаться и всегда останется < 5.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кто с решением, буду . составьте программу, которая вводит с клавиатуры три целых числа: a, b, c (каждое число - с новой строки) и выводит на экран минимальное из них. ничего, кроме этого числа программа выводить не должна.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cmenick29
andr77716
evatautes
vasilevam
ЕленаАнастасия315
margo929
egorov
centrprof20
TrofimovAnastasiya828
sochi-expert
avdeevau807
rabchek145200614
Ferrigen
gallows-warlike-0z
mdclcompany
▲