Galina-Marat1096
?>

Составить алгоритм и написать программу вычисления значений функции f (х) на отрезке [a; b] c шагом h.результат представить в виде таблицы, первый столбец которой - значение аргумента, второй - соответствующие значения функции. f(x)=2cosx-1

Информатика

Ответы

alisapavlushina
Var   a, b, h, x: real; begin   writeln('введите начальное значение, конечное значение и шаг ');   readln(a, b, h);   x : = a;   while x < = b do   begin       writeln(x: 5: 2,' ',2 * cos(x) - 1: 10: 7);       x : = x + h   end end. тест: введите начальное значение, конечное значение и шаг -1.8 1.6 0.2 -1.80 -1.4544042 -1.60 -1.0583990 -1.40 -0.6600657 -1.20 -0.2752845 -1.00  0.0806046 -0.80  0.3934134 -0.60  0.6506712 -0.40  0.8421220 -0.20  0.9601332   0.00  1.0000000   0.20  0.9601332   0.40  0.8421220   0.60  0.6506712   0.80  0.3934134   1.00  0.0806046   1.20 -0.2752845   1.40 -0.6600657   1.60 -1.0583990
tanysha1990
Var   a, b, h: real; begin   writeln('a b h');   readln(a, b, h);   writeln('=================');   repeat     writeln('|', a: 3, 2 * cos(a) - 1: 12: 7, '|');     a += h;   until (a > b);   writeln('================='); end. табличка: )
gnsnodir5001

  пусть х - время в секундах.

    тогда

      (1/3 *   60/8 мбайт/с * x) с - время   за треть времени)

      (2/3 * 90/8 мбайт/с * x) с - время за две третти времени

      тогда уравнение получается

      1/3 *   60/8   * x   +   2/3 * 90/8 * x = 1200

      2,5x +   7,5x = 1200

          10x = 1200

          x = 120

        получается 120 секунд или 120/60 = 2 минуты

forwandy42

компа́кт-диск -  оптический носитель информации в виде диска с отверстием в центре, информация с которого считывается с лазер

флэш-карта -  устройства, выполненные на одной микросхеме (кристалле) и не имеющие подвижных частей, основаны на кристаллах электрически перепрограммируемой флэш-памяти

оперативная память-устройство, 

  предназначенное для хранения обрабатываемой информации (данных) и программ, процессором  обработки информации кэш-память  – устройство, имеющее короткое время доступа к данным. встроенная в микросхему сверхбыстрая память. обычно имеет размер 256 или 512 кбайт, в мощных компьютерах до 1гб и более.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить алгоритм и написать программу вычисления значений функции f (х) на отрезке [a; b] c шагом h.результат представить в виде таблицы, первый столбец которой - значение аргумента, второй - соответствующие значения функции. f(x)=2cosx-1
Ваше имя (никнейм)*
Email*
Комментарий*