akuznecov8989
?>

1)вывести в обратном порядке второе слово строки. подсчитать количество букв в нем. 2) составить программу для вычисления т=(r/q+1)+s. r - наименьший элемент массива; q - произведение элементов массива с нечетными номерами; s - количество элементов, лежащих в интервале (a, b) (ввести с клавиатуры 3) вычислить среднее арифметическое положительных элементов матрицы, расположенных ниже побочной диагонали. закрасить указанные элементы.

Информатика

Ответы

irinanikulshina144
Var   x: string;   arr: array of char; begin   readln(x);   arr : = x.split(' ')[1].tochararray();   system.array.reverse(arr);   writeln(length(arr), '   ', new string(arr)); end. var   c: array of integer : = (10, 20, 10, 30, 40, 50, 55, 1, 5, 9, 4, 3, 2);   r, q, s: real;   i, a, b: byte;     begin   q : = 1;   i : = 1;   r : = c.min();   while (i < length(c)) do   begin     q *= c[i];     i += 2;   end;   readln(a, b);   s : = b - a - 1;   writeln('t = ', (r / q + 1) + s); end. const   k = 5;   p = 5; var   f: array [1..k, 1..p] of string;   o: real;   df: byte; begin   for i: byte : = 1 to k do   begin     for j: byte : = 1 to p do     begin       f[i, j] : = random(10, 99).tostring();       write(f[i, j]: 3);       if (j > = 7 - i) then       begin         o += integer.parse(f[i, j]);         df += 1;         f[i, j] : = '██';       end;     end;     writeln();   end;   writeln();   for i: byte : = 1 to k do   begin     for j: byte : = 1 to p do       write(f[i, j]: 3);     writeln();   end;   writeln(o / df); end.
irina25095462

#include <stdio.h>

 

#define N 2

 

double matrix[N][N] = {

   { 1.0, 2.0 },

   { 3.0, 4.0 }

};

 

unsigned long long find_min_max()

{

   double max = matrix[0][0];

   int line_max = 0;

   double min = matrix[0][0];

   int column_min = 0;

   for( int i = 0; i < N; ++i ) {

       for( int j = 0; j < N; ++j ) {

           if( matrix[i][j] > max ) {

               max = matrix[i][j];

               line_max = i;

           }

           if( matrix[i][j] < min ) {

               min = matrix[i][j];

               column_min = j;

           }

       }

   }

   return ((unsigned long long)line_max << 32) + (unsigned long long)column_min;

}

 

double calc_product(int line, int column)

{

   double sum = 0.0;

   for( int i = 0; i < N; ++i ) {

       sum += matrix[i][column] * matrix[line][i];

   }

   return sum;

}

 

int main() {

 

   unsigned long long line_max = find_min_max();

   unsigned long long column_min = line_max & 0x;

   line_max >>= 32;

   double product = calc_product((int)line_max, (int)column_min);

   printf("product = %f\n", product);

 

   return 0;

}

Объяснение:

vlrkinn
Смотря какая  быстрозавариваемой допустим это ролтон, тогда  алгоритм такой. 1) раскрываем пакетик 2) вываливаем лапшу  в тарелку 3) добавляем специи 4) завариваем лапшу если не следовать алгоритму, то нет смысла его использовать. например, вначале выполним пункт 2 и 3, а затем 1 и 4. что у нас получится? нарушая пункт 1 мы переходим к пункту 2, но тут проблема, мы не можем вывалить лапшу, ведь мы не открыли пакетик. здесь идет явное нарушение алгоритма и дальнейшее его использование не валидно.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)вывести в обратном порядке второе слово строки. подсчитать количество букв в нем. 2) составить программу для вычисления т=(r/q+1)+s. r - наименьший элемент массива; q - произведение элементов массива с нечетными номерами; s - количество элементов, лежащих в интервале (a, b) (ввести с клавиатуры 3) вычислить среднее арифметическое положительных элементов матрицы, расположенных ниже побочной диагонали. закрасить указанные элементы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kartyshkinaaa
Бегун-Марина
Dr-motoshop
artem032100
milkamilka1998
Александрович Владимирович
lovely138887
romashka17-90
Семеновна-Павел
NikolayGoncharov
rpforma71189
filimon131262
agutty3
Irinagarmonshikova
ryadovboxing
▲