Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу организующую хранение в файле нескольких записей (до 10) о результатах экзамена. каждая запись содержит 3 поля: номер записи, фамилия, оценка. организуйте вывод всей информации по форме: { 1 иванов 3 }
program fantscrin;
const n = 20;
var a: array [1..n] of integer;
i,max,k: integer;
begin
for i: =1 to n do
a[i]: = random(21)-10;
for i: =1 to n do
write(a[i], ' ');
max: =a[1];
k: =1;
writeln('');
for i: =2 to n do
if (a[i]> max) then
begin
max: =a[i];
k: =i;
end;
i: =a[1];
a[1]: =a[k];
a[k]: =i;
for i: =1 to n do
write(a[i], ' ');
end.