makscska22879
?>

Составить программу! надо ракета запускается с земли со скоростью v(км час) в направлении движения земли по орбите вокруг солнца. составить программу, определяющую результат запуска ракета в зависимости от скорости v. известно, что при v16, 4 ракета покинет солнечную систему.

Информатика

Ответы

Ирина
Var v: real; begin write('введите скорость в км/c: '); readln(v); if v< 7.9 then     writeln('ракета упадет на землю'); if v=7.9 then     writeln('ракета будет двигаться вокруг земли по круговой орбите'); if (v> 7.9) and (v< 11.2) then     writeln('ракета будет двигаться вокруг земли по эллиптической орбите'); if v=11.2  then     writeln('ракета будет двигаться вокруг солнца по круговой орбите'); if (v> 11.2) and (v< 16.4) then     writeln('ракета будет двигаться вокруг солнца по эллиптической орбите'); if v> 16.4 then writeln('ракета покинет солнечную систему'); end.
Елена-Семенова
Решение на vb sub rocket()       dim x as single       x = inputbox("введите скорость ракеты в км/с")       select case x       case is < 7.91               msgbox "ракета упадет на землю"       case 7.91               msgbox "ракета будет вращаться вокруг земли по круговой орбите"       case is < 11.2               msgbox "ракета будет вращаться вокруг земли по эллиптической орбите"       case is < 16.4               msgbox "ракета будет способна перемещаться в пределах солнечной системы"       case else               msgbox "ракета покинет солнечную систему"       end select end sub
Maksimova1320

var a: array [1..100,1..100] of integer; i,j,s,sn,n,m: integer; begin      read(n,m);       for i: = 1 to n do            for j: = 1 to m do begin                  read(a[i,j]);                   if (j> i) and (a[i,j]> 0) then begin                        sn: =sn+1;                         s: =s+a[i,j];                   end;             end;       writeln(s,sn); end.

borisov

 

1. я не знаю с какой дескретностью осуществляется поворот, однако результатом будут

а) горизонтальная линия вдоль верхней кромки экрана начинающаяся в точке 0,0

б)  вертикальная линия вдоль левой кромки экрана начинающаяся в 2 шагах от точки 0,0

 

  в) линия произвольного наклона начинающаяся в двух шагах от точки 0,0 и идущая до края экрана

 

 

  2. а) вначале дойдем до края экрана

пока впереди не край  прыжокконец цикла

б) повернем указатель в сторону угла и загоним указатель в угол

пока впереди край  поворотконец цикла

 

пока впереди не край  прыжокконец цикла

в) начинаемрисовать пунктир до следующего угла и там поворачиваем

пока впереди не край  шаг

  прыжокконец цикла

пока впереди край  поворотконец цикла

г) повторяем пункт в еще 3 раза

итоговая программа

 

 

пока впереди не край  прыжокконец цикла 

пока впереди край  поворотконец цикла

пока впереди не край  прыжокконец цикла

i: =0

пока i< 4

 

  пока впереди не край    шаг

    прыжок  конец цикла

  пока впереди край    поворот  конец цикла

  i : = i+1

конец цикла

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу! надо ракета запускается с земли со скоростью v(км час) в направлении движения земли по орбите вокруг солнца. составить программу, определяющую результат запуска ракета в зависимости от скорости v. известно, что при v16, 4 ракета покинет солнечную систему.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Анатольевич1707
pashyanaram
f-d-a-14
yyyaga
forwandy42
echervyakov
mixtabak2
Ivanovich_Kostik898
Batrakova-Anna
Суравцова_Алексей669
ivanovk3599
buhtovarish
a580028r
minaskorolev8
Мусаев Игоревич371