firsova5911
?>

Составьте программу или блок-схему для решения следующей . учитель за урок ставит а двоек, в троек, с четвёрок, d пятёрок (а, в, с и d каждый день разные сколько двоек, троек, четвёрок и пятёрок поставит учитель за учебную неделю.

Информатика

Ответы

forwandy42

var prost: array [1..100] of integer;   i, max, n, j: integer;   is_prost: bool; begin  max : = 99;   prost[1] : = 2;   n : = 1;   for i : = 2 to max do begin      is_prost : = true;       for j : = 1 to n do begin          is_prost : = is_prost and not (i mod prost[j] = 0);       end;       if is_prost then begin          n : = n + 1;           prost[n] : = i;       end;   end;   for i : = 1 to n do      if prost[i] > 9 then write(prost[i], ' '); end.

Мунировна

const  n = 99; var  p: array[2..n] of boolean;   i, pr: integer;   flag: boolean; begin  for i : = 2 to n do      p[i] : = true;   pr : = 2;   flag : = true;   while flag do  begin      i : = 2 * pr;       while i < = n do      begin          p[i] : = false;           i : = i + pr;       end;       flag : = false;       for i : = pr + 1 to n do          if p[i] then          begin              pr : = i;               flag : = true;               break;           end;   end;     for i : = 10 to n do      if p[i] then          write(i, ' ');   readln; end.моя быстрее работает : р 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу или блок-схему для решения следующей . учитель за урок ставит а двоек, в троек, с четвёрок, d пятёрок (а, в, с и d каждый день разные сколько двоек, троек, четвёрок и пятёрок поставит учитель за учебную неделю.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kogakinoa
orantus3
Shtorm-Shoe
Aleksandrovich1075
dima0218687
gunel1988alieva
Ольга1915
eronch
Лежачёва355
ПетросовичЗаславский
Назначение всех клавиш клавиатуры (, )
nairahay
atvkaprolon
Марина566
Ohokio198336