keshka12719
?>

Паскаль написать программу, которая будет открывать txt файл, искать нужный текст и удалять его.после чего сохранит изменения. нужно использовать цикл, т.к.поиск будет осуществляться много раз! txt файл большой, с большим количеством перехода на новую строку.

Информатика

Ответы

Oslopova
Только в среде pascal.abc.net ! лучше писать результат не в тот же файл, а в другой: при составлении регулярных выражений без достаточного опыта можно легко ошибиться. uses   system.text.regularexpressions; const   crlf = #13#10; var   s, sbig: string;   fin, fout: text; begin   assign(fin, 'myin.txt');   reset(fin);   sbig : = '';   while not eof(fin) do   begin       readln(fin, s);       sbig : = sbig + s + crlf   end;   close(fin);   {пример - уладить подстроки, начиная с "http: " и до первого пробела,   причем внутри подстроки может встретиться переход на новую строчку.   используется шаблон '\bhttp: \s+' - подробности: регулярные выражения}   sbig: =regex.replace(sbig, '\bhttp: \s+', '', regexoptions.multiline);   assign(fout, 'myout.txt');   rewrite(fout);   write(fout, sbig);   close(fout);   writeln('конец работы'); end.
vladimirkirv
#include< bits/stdc++.h> using namespace std; const int n = 1e6+1; long long n; long long a[n], b[n]; int main() { setlocale(lc_all, "rus"); scanf("%i64d", & n); for( int i = 0 ; i < n ; i ++ ) cin > > a[i]; b[0] = a[0]; b[n-1] = a[n-1]; for( int i = 1 ; i < n-1 ; i ++ ) b[i] = a[i] + a[i+1]; cout < < "массив а: \n"; for( int i = 0 ; i < n ; i ++ ) cout < < a[i]; cout < < "\nмассив b: \n"; for( int i = 0 ; i < n ; i ++ ) cout < < b[i]; return 0; }
Маркина Ворошилина
1. короткий современный вариант ("один оператор") // pascalabc.net 3.1, сборка 1230 от 27.04.2016 begin   writeln('sпол.неч = ',arrrandom(50,-10,20).println       .where((x,i)-> (x> 0) and (i.) end. тестовое решение 15 16 0 17 20 7 -3 -4 9 9 -3 -8 14 10 10 11 7 18 -8 8 0 15 1 4 11 1 9 -10 -7 -7 12 17 8 13 7 15 1 13 12 11 4 -5 -3 -6 -5 -10 -9 -8 8 -8 sпол.неч = 148 2. длинный "школьный" вариант ("почувствуйте разницу") // pascalabc.net 3.1, сборка 1230 от 27.04.2016 var   a: array[1..50] of integer;   i,s: integer; begin   randomize;   s: =0;   for i: =1 to 50 do begin       a[i]: =random(31)-10; write(a[i],' ');       if (a[i]> 0) and odd(i) then s: =s+a[i]       end;   writeln;   writeln('sпол.неч = ',s) end. тестовое решение 4 14 4 7 9 -4 3 6 20 -10 3 -3 15 12 9 0 3 12 13 -1 9 -2 -2 16 18 -2 5 9 17 -3 4 -6 10 10 -5 10 8 13 12 15 13 1 12 1 7 6 9 2 -9 -6 sпол.неч = 207

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль написать программу, которая будет открывать txt файл, искать нужный текст и удалять его.после чего сохранит изменения. нужно использовать цикл, т.к.поиск будет осуществляться много раз! txt файл большой, с большим количеством перехода на новую строку.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tanias
saint158
petrowanastya202081
bulk91675
sv455umarketing74
monolit-kolomna
ver2bit
Vetroff-11
com4047797
cernovarmechta
Test Станислав
alexeytikhonov
Zimin1111
Михайловна-Гусева350
volna22051964
▲