Dmitrievich1871
?>

Язык pascalabc или python максимальные . с клавиатуры вводятся координаты (x, y) двух точек a и b (координаты могут быть отрицательными, положительными или нулевыми)нужно написать программу, которая находит расстояние от точки a до b

Информатика

Ответы

barnkim

ответ:

program zz1;

var x1, x2, y1, y2, d: real; //задаем переменные не целого типа

begin

write(' введите координаты точки а '); // вводим с клавиатуры координату х и координату у первой точки

read(x1, y1);  

write('введите координаты точки b '); // вводим с клавиатуры координату х и координату у второй точки

read(x2, y2);

d: =sqrt(sqr(x1 - x2) + sqr(y1 - y2));     // находим длину отрезка по формуле

write(' длина отрезка ab = ', d: 5: 2); // выводим ответ в формате пять знаков для числа и два знака после точки

end.

arturusinsk5
Теоретической основой информатики является группа наук таких как: теория информации, теория алгоритмов, логика, теория формальных языков и грамматик, комбинаторный анализ и т.д. кроме них информатика включает такие разделы, как архитектура эвм, операционные системы, теория баз данных, технология программирования и многие другие. важным в определении информатики как науки является то, что с одной стороны, она занимается изучением устройств и принципов действия средств вычислительной техники, а с другой – систематизацией приемов и методов работы с программами, этой техникой. информационная технология – это совокупность конкретных технических и программных средств, с которых выполняются разнообразные операции по обработке информации во всех сферах нашей жизни и деятельности. иногда информационную технологию называют компьютерной технологией или прикладной информатикой. информация аналоговая и цифровая. термин «информация» восходит к латинскому informatio,– разъяснение, изложение, осведомленность. информацию можно классифицировать разными способами, и разные науки это делают по-разному. например, в философии различают информацию объективную и субъективную. объективная информация отражает явления природы и человеческого общества. субъективная информация создается людьми и отражает их взгляд на объективные явления. в информатике отдельно рассматривается аналоговая информация и цифровая. это важно, поскольку человек своим органам чувств, привык иметь дело с аналоговой информацией, а вычислительная техника, наоборот, в основном, работает с цифровой информацией.
cvetprint
Основные характеристики процессоров что такое процессор с горем пополам знают многие люди, но как разбираться в технической документации к нему. что в прайсе значат непонятные цифры и другие подобные вопросы осилит далеко не каждый пользователь. да и порой знатоки компьютера не всегда четко представляют, что значит разрядность, например. давайте продолжим разбирать основные характеристики процессора. 1.количество ядер  — этот параметр показывает количество одновременно работающих программ. но не думайте, что если вы запустите word и winamp на компютере с одним ядром, что у вас программы работают одновременно. они работают последовательно переключаясь с одной на другую, но делают это так быстро, если у вас быстрый компьютер, что мы этого не замечаем.количество ядер в последнее время прочно вошло в основные характеристики процессора, что многие ошибочно полагают, что если ядер больше, то всегда будет прирост производительности. к сожалению если программа не оптимизирована под 4 ядра, то вы хоть убейтесь она 4 ядра использовать не будет.нужна ли многоядерность? 2.частота процессора  — это скорость с которой происходит обмен данными между процессором и системной шиной компьютера. её любят указывать продавцы в прайсах. измеряется точно также как тактовая частота и по понятным причинам всегда ниже. 3.коэффициент умноженияили умножение) – он нужен, чтобы получить тактовую частоту процессора. частоту шины вам нужно умножить коэффициент. помнить нужно только одно в процессорах intel есть одна полезная технология со смешным названием quad pumping — так вот она позволяет передать 4 блока данных за такт, поэтому маркетологи пользуются этим и преувеличивают в 4 раза частоту шины. 4.тепловыделение процессора  — измеряется в ватах. простым языком если сказать, то показывает какой мощности у вас должен быть вентилятор(кулер), чтобы обеспечить бесперебойную работу. это важный параметр для любителей повыделываться и разгонять процессоры выше номинала. 5. максимальная рабочая температура  — всё то, что вы прочитали о тепловыделении можно отнести и к температуре. если вы превысите максимум, то процессор перегреется, и вполне возможно компьютер или выключится или сам начнет перезагружаться. 6.поддержка различных технологий  — если в прайсе вдруг через запятую перечисляются непонятные для вас технологии типа sse2 или 3dnow, то знайте, что это хорошо. мир не стоит на месте, вот и производители придумывают разные фишки для лучшей работы процессора. это всё равно, что на соковыжималке будет написано, «а ещё она умеет шинковать кубиками, колечками и посуду моет». чем больше функциональности тем лучше. ну вот так примерно в двух частях и рассказаны были основные характеристики процессора. и т.д

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык pascalabc или python максимальные . с клавиатуры вводятся координаты (x, y) двух точек a и b (координаты могут быть отрицательными, положительными или нулевыми)нужно написать программу, которая находит расстояние от точки a до b
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tatyana1426
Nonstop788848
Алексей Шуклин
miumiumeaow
Mikhailovna_Litvinova276
Semenovt
svetavalera
Xeniya91
rimmaskis
Татьяна902
albina6580
Olga-Rauisovna
maglevanyycpt
dmitrovlug8248
abrolchik8511