Вцикле проверяете (a mod 2) равно ли нулю, то бишь равен ли нулю остаток. если да - число четное. одновременно с этим первое четное число кладете в переменную max, а остальные четные сравниваете с этой переменной, если какое-то число больше - его кладете в переменную max. ясно? если нет, могу написать программу, но лучше чтобы вам было ясно upd: можно через массивы, но это не хардкорно a, max, counter : integer; begin max : = 0; for counter = 1 to 15 do begin writeln("write ur number: "); readln(a); if (a mod 2) = 0 then if a > max then max : = a; end; writeln(max); readln(); end. ––––––––––––––––––––––––––––––––––– вам б-г
//pascal abc.net v3.1 сборка 1172 const n=6; var f,h: text; i,maxi: integer; ar: array[1..n] of real; begin ar[6]: =real.minvalue; assign(f,'text.txt'); rewrite(f); for i: =1 to n-1 do begin readln(ar[i]); if ar[i]> ar[6] then begin ar[6]: =ar[i]; maxi: =i; end; end; ar[maxi]: =ar[maxi]/2; writeln('f: '); for i: =1 to n do begin write(f,ar[i],' '); write(ar[i],' '); end; close(f); writeln; i: =0; writeln('h: '); assign(h,'text1.txt'); rewrite(h); while i< n do begin i: =i+2; write(h,ar[i],' '); write(ar[i]: 4); end; close(h); end. пример ввода: 1 2 3 4 5 пример вывода: f: 1 2 3 4 2.5 5 h: 2 4 5
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Впоследовательности из 15 целых чисел найти максимальный элемент из четных. написать программу)