R7981827791127
?>

Pascal abc 1 составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат . 2 составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Информатика

Ответы

axo4937
1. program zadacha; uses crt; var a: integer; begin clrscr;           write('введите целое число не равное нулю a = ');           readln(a);           writeln;           if a< 0 then           write('число a отрицательное, результат = ', a*a)                     else           write('число a положительное, результат = ', a/2); end. 2. program chetnost; uses crt; var a: integer; begin clrscr;           write('введите целое число a = ');           readln(a);           writeln;           if (a mod 2) = 1 then           write('да')           else           write('нет'); end.
semenoffufc8
Первая программа ,если не нравится исправлю добавил вторую
chizhenkovd9

1 Модель (информатика) — система, исследование которой служит средством для получения информации о другой системе

напишите значение буквы D в понятии 3D модель

ответ

3-dimensional, dimensional в переводе с английского означает "мерный", "размерный"

3-2D, или двумерная графика — раздел компьютерной графики, работающий с изображением, формируемым в двух измерениях, обладающим только двумя параметрами — шириной и высотой. 2D еще называется изображением плоским.ЗD, или трехмерная графика — раздел компьютерной графики, объектом которого является изображение, формируемое в трех измерениях, к параметрам которого добавлена глубина. Проще говоря, 3D — это объемное изображение.

4

printdecor

Программа - вариант реализации алгоритма для обработки данных.

Программу тоже можно рассматривать как данные и производить с ней манипуляции. Например, если рассматривать программу как текст то её можно модифицировать в другой программе. А программу, уже загруженную в оперативную память можно рассматривать как последовательность байт, которые можно модифицировать.

P.S. Компиляторы и парсеры делают не сильно сложную работу. Они рассматривают поток текста как некие синтаксические сущности и на их основе создают понятные для компьютера вычислимые сущности. Тот код, который ты пишешь - просто текст. А вся магия в метаописании сущностей.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal abc 1 составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат . 2 составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Popova838
Светлана
Тресков946
sanhimki47
gunel1988alieva
irinaastapova2011
ivanova229
Kuznetsova1639
Белов_Лукина1339
vorota-grupp
MikhailovnaAnastasiya
Klyucharyova
KrisTinka
lsyrbu
format-l3364