dnikolay365
?>

Написать программу в паскале! надо! задана последовательность целых чисел, количество которых не превосходит 100.требуется определить за один проход элемент с максимальным значением, а также число его повторений в последовательности.

Информатика

Ответы

leeka152522
Program maxof; var ar: array [1..100] of integer; i, j, posl: shortint; max: integer; begin readln(i); for j: =1 to i do begin readln(ar[j]); end; max: =ar[1]; posl: =1; for j: =2 to i do begin if max = ar[j] then inc(posl); if max < ar[j] then begin posl: =1; max: =ar[j] end;   end; writeln(max, ' x', posl); end.
kalina1372
Var   i,k,max: integer;   a: array[1..100]of integer; begin writeln('исходная последовательность: '); for i: =1 to 100 do   begin   a[i]: =random(200);   write(a[i],' ');   if a[i]> max then     begin     max: =a[i];     k: =1;     end;   if a[i]=max then     k: =k+1;   end; writeln; writeln('максимальное значение: ',max); writeln('число повторений: ',k) end.
kamimoza
Информативность сообщения область взаимодействия между человеком, воспринимающим текст, и информационной насыщенностью текста, обусловленная избирательной способностью воспринимающего человека, т.е. пределом различимости. для различимости, т.е. понимания смысла высказывания, переводчику необходимо применить весь предыдущий опыт или знание обстановки общения именно к данному языковому содержанию. информативность сообщения основывается на следующих требованиях: (1) синтаксических, согласно которым смысл должен быть логически вводим из наблюдаемого соотношения языковых единиц. это означает, что переводчик должен установить принадлежность исходного текста к определенной знаковой системе по характеру отношений между знаками, составляющими текст; (2) семантических, согласно которым смысл, выводимый из данного соотношения языковых единиц, отражает то или иное состояние реальной действительности, включая вымысел. это означает, что переводчик должен соотнести языковое содержание данного текста со смыслом (отражение реальной или вымышленной ситуации); (3) прагматических, согласно которым в смысл, придаваемый тексту, включается оценка как отраженной действительности, так и способа ее отражения. это означает, что переводчик должен дать оценку, близкую к авторской или соответствующую непосредственным перевода.
strannaya2018
Сколько элементов массива? допустим, 10. var a: array [1..10] of integer; i, min, max, imin, imax: integer; begin for i: =1 to 10 do read(a[i]); min: =a[1]; max: =a[1]; for i: =1 to 10 do begin if a[i] > max then begin max: =a[i]; imax: =i; end; if a[i] < min then begin min: =a[i]; imin: =i; end; end; if imin< imax then for i: =(imin+1) to (imax-1) do a[i]: =sqr(a[i]) else for i: =(imax+1) to (imin-1) do a[i]: =sqr(a[i]); writeln('максимальное значение: ', max, ', минимальное: ', min); for i: =1 to 10 do write(a[i], ', '); end. немного пояснений: по условию, только элементы между минимумом и максимумом возводятся в квадрат, отсюда эти imax-1 и imin+1. пример действия: 1 2 4 999 765 624 0 83 64 63 максимальное значение: 999, минимальное: 0 1, 2, 4, 999, 585225, 389376, 0, 83, 64, 63,

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале! надо! задана последовательность целых чисел, количество которых не превосходит 100.требуется определить за один проход элемент с максимальным значением, а также число его повторений в последовательности.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

amayonova
Peshkov
aidapiltoyan43
Anshel2018534
vickuznetsova8677
missmorozova2
ВалентиновичСуриковна1104
Immortal3331
spz03
AleksandrovnaIgor
tanya14757702
Tatianamir765654
archala
vladimirdoguzov
orgot9