la-ronde737
?>

Решить на языке программирования pascal. в текущем месяце бригада в каждый последующий день работы выпускала на три изделия больше, чем в предыдущий. в первый день было выпущено 42 изделия, что составило 67% дневной нормы. в месяце 26 рабочих дней. сумеет ли бригада выполнить месячную норму?

Информатика

Ответы

dmitrymakarov003
Var  i,x,s,n: integer;   begin  x: =42;   n: =round(42/67*100)*26;   for i: =1 to 26 do     begin     s: =s+x;     x: =x+3;     end;   writeln('норма: ',n); writeln('сделано: ',s); if s> =n then writeln('норма выполнена')   else writeln('норма не выполнена'); end. 
Элизбарян
Var i: integer; answer: integer; n: integer; begin answer: =42; n: =trunc(42/67)*100; for  i: =1  to  26  do begin answer: =answer+3; if answer then  writeln(i,'бригада  не  выполнила  норму') else  writeln(i,'бригада  выполнила  норму'); end; end.
optikaleks7
Проведем некоторые преобразования. наиболее вероятное предположение, что s2 - формула площади круга с диаметром dr, а s1 - формула площади квадрата со стороной a и диагональю dg. в программа сравнивается диагональ квадрата и диаметр окружности и если диагональ меньше диаметра, выводится "да", в противном случае выводится нет. это позволяет сделать предположение о следующей постановке : "можно ли поместить брусок квадратного сечения с площадью s1 в полый цилиндр с площадью основания s2 ? ". или, как вариант, пройдет ли брусок в отверстие..
Vyacheslav_Nikolaevna
Судя по коду, я нашёл значения переменных: - площадь квадрата, вписанного в круг. - площадь круга. - диагональ квадрата. - диаметр круга. - сторона квадрата. далее, разберём сам код: с самого начала программа предлагает ввести площадь квадрата и площадь круга ("writeln('введите s1 и s2: ');   ") и записывает введённые значения в переменные  и  соответственно (readln(s1, s2);   ). следующее действие программы - " a : = sqrt(s1);   " - не что иное, как вычисление длины стороны квадрата из площади( ). далее - "dg : = a * sqrt(2);   " - программа вычисляет диагональ квадрата, который вписан в круг, с формулы  . следующий шаг программы - "dr : = sqrt(4 * s2 / pi); " - вычисляет диаметр круга согласно формуле  , которая выведена из формулы площади круга:   следующими действиями программа сравнивает два диаметра, один из которых был получен путём использования значений квадрата, а другой - значений круга. то есть, программа, сравнивая эти два значения диаметра, определяет, может ли квадрат быть вписан в круг, согласно данных,  введённых пользователем, о площадях этих двух фигур. текст может быть сформулирован так же: напишите программу, которая бы определяла, может ли быть вписан квадрат в круг, исходя из значений их площадей, введённых пользователем.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на языке программирования pascal. в текущем месяце бригада в каждый последующий день работы выпускала на три изделия больше, чем в предыдущий. в первый день было выпущено 42 изделия, что составило 67% дневной нормы. в месяце 26 рабочих дней. сумеет ли бригада выполнить месячную норму?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

milenaochirova01017424
terma-msk1
djevgen
Poroskun
shneider1969
николаевич-Елена988
Larya
simonovaliubov5852
Равиль_Евгеньевич1808
NIKOLAI
urazmetova
Yurok9872
retropluse832
info40
mariyachervonnaya44
▲