format-l3364
?>

Даны 3 целых числа составить программу для вычисления суммы этих чисел и произведения этих чисел

Информатика

Ответы

Светлана-Тигран
Program z; var a,b,c,x: integer; begin readln(a,b); c: =a+b; x: =c*b; writeln(c); writeln(x); end.
Горина

закономерность количества символов:

1)1

2)3

3)7

4)15

5)15*2+1=31

6)31*2+1=63

7)63*2+1=127

 

так как каждом действии концовка наших символов с 4 строки не сильно-то и изменяется, то присваиваем каждой букве число справа налево счтитая от 127 до 120

  a     c   b     a     a     b   a     a 

                                  20   21   22   23   24   25   26   27 

ответ: acba

anatolevich1931

1)

 

var a: integer;

begin writeln('сколько вам лет? '); readln(a); if a mod 10 = 1 then writeln('вам ', a, ' год'); if a > 20 then //если наш возраст, который больше 20, оканчивается на 2,3,4 то нам пишут "года") if (a mod 10 = 2) or (a mod 10 = 3) or (a mod 10 = 4) then writeln('вам ', a, ' года'); if a < 10 then //если наш возраст, который меньше 10, оканчивается на 2,3,4 то нам пишут "года") if (a mod 10 = 2) or (a mod 10 = 3) or (a mod 10 = 4) then writeln('вам ', a, ' года'); if a > 4 then //если нам от 5 до 19 лет, то нам пишут "лет") if a < 20 then writeln('вам ', a, ' лет'); if a > 20 then //если наш возраст, который больше =20, оканчивается на 0,5,6,7,8,9 то нам пишут "лет") if (a mod 10 = 0) or (a mod 10 = 5) or (a mod 10 = 6) or (a mod 10 = 7) or (a mod 10 = 8) or (a mod 10 = 9) then writeln('вам ', a, ' лет'); end.

 

2)

 

var a: integer; d: string;

begin write('введите сегодняшнее число '); readln(a); write('введите название месяца в именительном падеже '); readln(d); if d = 'январь' then if a = 31 then writeln('завтра будет 1 февраля') else writeln('завтра будет ', a + 1, ' января'); //январь if d = 'февраль' then if a = 28 then writeln('завтра будет 1 марта') else writeln('завтра будет ', a + 1, ' февраля'); //февраль if d = 'март' then if a = 31 then writeln('завтра будет 1 апреля') else writeln('завтра будет ', a + 1, ' марта'); //март if d = 'апрель' then if a = 30 then writeln('завтра будет 1 мая') else writeln('завтра будет ', a + 1, ' апреля'); //апрель if d = 'май' then if a = 31 then writeln('завтра будет 1 июня') else writeln('завтра будет ', a + 1, ' мая'); //май if d = 'июнь' then if a = 30 then writeln('завтра будет 1 июля') else writeln('завтра будет ', a + 1, ' июня'); //июнь if d = 'июль' then if a = 31 then writeln('завтра будет 1 августа') else writeln('завтра будет ', a + 1, ' июля'); //июль if d = 'август' then if a = 31 then writeln('завтра будет 1 сентября') else writeln('завтра будет ', a + 1, ' августа'); //август if d = 'сентябрь' then if a = 30 then writeln('завтра будет 1 октября') else writeln('завтра будет ', a + 1, ' сентября'); //сентябрь if d = 'октябрь' then if a = 31 then writeln('завтра будет 1 ноября') else writeln('завтра будет ', a + 1, ' октября'); //октябрь if d = 'ноябрь' then if a = 30 then writeln('завтра будет 1 декабря') else writeln('завтра будет ', a + 1, ' ноября'); //ноябрь if d = 'декабрь' then if a = 31 then writeln('завтра будет 1 января') else writeln('завтра будет ', a + 1, ' декабря'); //декабрьend.

 

3)

 

vara,b,c,x,y,z: integer;

begin writeln ('введите число, месяц и год рождения певрого человека'); write ('число - '); readln(a); write ('месяц - '); readln(b); write ('год - '); readln(c); writeln ('введите число, месяц и год рождения второго человека'); write ('число - '); readln(x); write ('месяц - '); readln(y); write ('год - '); readln(z); if c> z then writeln ('второй человек старше'); //проверка одного условия if c=z then//проверка 2х условий if b> y then writeln ('второй человек старше'); // if c=z then//проверка 3х условий if b=y then // if a> x then writeln ('второй человек старше'); // проверка для второго человека окончена if c< z then writeln ('первый человек старше'); //проверка одного условия if c=z then//проверка 2х условий if b< y then writeln ('первый человек старше'); // if c=z then//проверка 3х условий if b=y then // if a< x then writeln ('первый человек старше'); // if c=z then//проверка на равенство возрастов if b=y then if a=x then writeln('люди имеют одинаковый возраст'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны 3 целых числа составить программу для вычисления суммы этих чисел и произведения этих чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Galinagol559
vik1223
lider123
dariamay1996
Borg Fedak1162
Новицкий1107
Dimston134877
dianakryukova00
Михаил1121
Кирилл-Анна1023
akinin95
vadimkayunusov
Stepanovich_Makarov
kirillboytsov403
reinish23
▲