Дано множество точек с координатами на плоскости. написать программу, которая использует подпрограммы и выведит на экран наименьшее расстояние между двумя точками.
Const nm = 50; {максимальная длина массива} type mas = array[1..nm] of real; var i, j, n: integer; x, y: mas; d, dmin: real; function sqrdist(p, q: integer): real; { возвращает квадрат расстояния между точками } begin sqrdist : = sqr(x[q] - x[p]) + sqr(y[q] - y[p]) end; begin write('введите количество точек -> '); readln(n); writeln('вводите координаты каждой точки (x,y) через пробел'); for i : = 1 to n do begin write('точка ', i, ': '); readln(x[i], y[i]); end; dmin : = 1e10; { значение, заведомо большее реально возможного } for i : = 1 to n do for j : = i + 1 to n do begin d : = sqrdist(i, j); if dmin > d then dmin : = d end; writeln('минимальное расстояние между точками равно ', sqrt(dmin): 0: 4) end. тестовое решение: введите количество точек -> 5 вводите координаты каждой точки (x,y) через пробел точка 1: 3.4 7.2 точка 2: -3 8.6 точка 3: -4.5 -5.1 точка 4: 6 -2 точка 5: 0 9 минимальное расстояние между точками равно 3.0265
vshumilov
26.03.2020
Через поле и лесок подаётся голосок. он бежит по - скажешь здесь, а слышно там. (телефон) под крышей - четыре ножки, на крыше - суп да ложки. (стол) хоть по объёму и мала, информацию хранит она. знаем все устройство это называется…… адрес, имя, телефоны, все запишет, все запомнит! и девчонке и мальчишке, всем эта книжка! скромный серый колобок, длинный тонкий проводок, ну а на коробке - две или три кнопки. в зоопарке есть зайчишка, у компьютера есть стоит весёлый, светлый дом. проворных много в нём. там пишут и считают, рисуют и читают.
karnakova-a
26.03.2020
I= 1, v = 5, х =10, l = 50, с = 100, d = 500, м = 1000 dc=600lxxx=80iv=4римские цифры, цифры древних римлян. система р. ц. основана на употреблении особых знаков для десятичных разрядов i = 1, х =10, с = 100, м = 1000 и их половин v = 5, l = 50, d = 500. натуральные числа записываются при повторения этих цифр. при этом, если большая цифра стоит перед меньшей, то они складываются (принцип сложения), если же меньшая — перед большей, то меньшая вычитается из большей (принцип вычитания). последнее правило применяется только во избежание четырёхкратного повторения одной и той же цифры. например, i, х, с ставятся соответственно перед х, с, м для обозначения 9, 90, 900 или перед v, l, d для обозначения 4, 40, 400. например, vi = 5+1 = 6,iv = 5 — 1 = 4 (вместо iiii). xix = 10 + 10 — 1 = 19 (вместо xviiii), xl = 50 — 10 =40 (вместо xxxx), xxxiii = 10 + 10 + 10 + 1 + 1 + 1 = 33 и т.д.