cosmetic89
?>

На pascal abc, решить используя type надо) составить программу которая создает файл каждая строка которого выглядет так: табельный номер, фио, оклад. ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад

Информатика

Ответы

asvirskiy26

var i,max: integer; fio: string; x: array[1..5] of integer;       f1,f2: text; begin  assign(f1, 'out.txt'); assign(f2, 'out2.txt');   rewrite(f1); rewrite(f2);   for i: =1 to 5 do    begin        writeln('daite fio ',i,'-ogo rabotnika'); readln(fio);         writeln('daite otklad rabotnika ',i); readln(x[i]);         writeln(f1, i,' ',fio,' ',x[i]); fio: ='';     end;     max: =x[1];     for i: =1 to 5 do if x[i]> max then max: =x[i];     writeln(f2, max);   close(f1); close(f2);   readln; end.

 

rabotatet! proveril v pascale

lele52
Пусть k(n) - количество звездочек, напечатанных при вызове f(n) тогда k(n) = 1 { writeln('*') } + k(n-2) {вызов f(n-2) -> печатается еще k(n-2) звездочек} + k(n div 2) {f(n div 2)} при n > 0 и k(n) = 1 при n < = 0 требуется найти k(7) k(7) = 1 + k(5) + k(3) k(5) = 1 + k(3) + k(2) k(3) = 1 + k(1) + k(1) k(2) = 1 + k(0) + k(1) k(1) = 1 + k(-1) + k(0) k(0) = k(-1) = 1 {0, -1 < = 0} k(1) = 1 + 1 + 1 = 3 k(2) = 1 + 1 + 3 = 5 k(3) = 1 + 3 + 3 = 7 k(5) = 1 + 7 + 5 = 13 k(7) = 1 + 13 + 7 = 21 ответ: 21
Юлия1972
Var a, b, c, d: integer; p: integer; begin writeln('введите первое число: '); readln(a); writeln('введите второе число: '); readln(b); writeln('введите третье число: '); readln(c); writeln('введите четвёртое число: '); readln(d); if a> b then writeln('1 число больше 2'); if a< b then writeln('1 меньше 2'); if b> c then writeln('2 число больше 3'); if b< c then writeln('2 меньше 3'); if c> d then writeln('3 число больше 4'); if c< d then writeln('3 меньше 4'); if c> d then writeln('4 число больше 1'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На pascal abc, решить используя type надо) составить программу которая создает файл каждая строка которого выглядет так: табельный номер, фио, оклад. ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yevgenii1423
ruslan
Николаевна Филиппов1936
georgegradoff122
smakarov76
Prokopeva1062
ganzashop
azarovaelena19812
AHO436
Fedorovich_Aleksandrovich685
multikbo3049
verynzik66525
Valerevna Tuzova
ИП-Сысоев1628
zabava-83
▲