Var n,sum: real; begin sum: =0; for i: =1 to 5 do begin write ('введите i, число); readln(n); if n< 0 then s: =s+n; end; writeln(; сумма пяти отрицательных чисел равна');
КириллЕгорова1906
11.10.2021
Пятизначное число состоит из пяти разрядов: так как единиц не существует, то каждый разряд (кроме первого) может принимать 9 вариантов (0, 2, 3, 4, 5, 6, 7, 8, 9). при этом, первый разряд не может быть нулём, так как число 5-значное. то есть число можно записать как yxxxx, где y принимает значения от 2 до 9, а x - девять значений (которые выше). количество чисел считаем по формуле где 8 - это количество вариантов первого разряда, а 9^4 - количество вариантов оставшихся четырех разрядов. то есть ответ 52488
mariia39
11.10.2021
#include < iostream> #include < stdio.h> using namespace std; int main(){ int y; cin> > y; y=y%12; switch (y){ case 4: {cout< < "mouse"; break; } case 5: {cout< < "bull"; break; } case 6: {cout< < "tiger"; break; } case 7: {cout< < "rabbit"; break; } case 8: {cout< < "dragon"; break; } case 9: {cout< < "snake"; break; } case 10: {cout< < "horse"; break; } case 11: {cout< < "goat"; break; } case 0: {cout< < "monkey"; break; } case 1: {cout< < "cock"; break; } case 2: {cout< < "dog"; break; } case 3: {cout< < "pig"; break; } } cin.get(); cin.get(); return 0; }
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, которая вычисляет сумму отрицательных чисел среди 5 чисел, которые вводятся с клавиатуры